./print/p5-LaTeX-Encode, Encode characters for LaTeX formatting

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.092.0, Package name: p5-LaTeX-Encode-0.092.0, Maintainer: pkgsrc-users

This module provides a function to encode text that is to be formatted with
LaTeX. It encodes characters that are special to LaTeX or that are
represented in LaTeX by LaTeX commands.

The special characters are: \ (command character), { (open group), }
(end group), & (table column separator), # (parameter specifier),
% (comment character), _ (subscript), ^ (superscript),
~ (non-breakable space), $ (mathematics mode).

Note that some of the LaTeX commands for characters are defined in the LaTeX
textcomp package. If your text includes such characters, you will need to
include the following lines in the preamble to your LaTeX document.

\usepackage[T1]{fontenc}
\usepackage{textcomp}

The function is useful for encoding data that is interpolated into LaTeX
document templates, say with Template::Plugin::Latex (shameless plug!).


Required to run:
[lang/perl5] [devel/p5-Readonly]

Required to build:
[devel/p5-Carp-Always] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 96381e63e5671d3b6ee298ec8be1e8c73f9ffbd5
RMD160: f51ddfdee9defe22c022c3c6ed8cab21de7a4522
Filesize: 45.224 KB

Version history: (Expand)


CVS history: (Expand)


   2017-09-18 14:08:12 by Thomas Klausner | Files touched by this commit (1)
Log message:
p5-LaTeX-Encode: remove reference to non-existent file
   2017-08-10 16:00:11 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.092.0

No upstream changelog found.
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-04-29 16:38:09 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 0.06 to 0.091.3
----------------------
2014-03-25  Chris Travers <chris.travers@gmail.com>
        * version 0.091.3
        * Further regexp fixes for 5.19 bracket handling

2014-03-24  Chris Travers <chris.travers@gmail.com>
        * version 0.091.1
        * Fixed Test Cases failing taint mode under Perl 5.12 and lower.

2014-03-23  Chris Travers <chris.travers@gmail.com>
        * version 0.09
        * Added additional test case for some entities to make verify table
        * Merged in LaTeX::Encode::EncodingTable

2012-09-30  Andrew Ford  <a.ford@ford-mason.co.uk>
        * version 0.08
        * change t/11-unmatched-chars.t to use an unmatched ideographic \ 
character instead
          of 0x{ffff} as some versions of perl protest about having an illegal \ 
Unicode
          character in a string.

2012-09-23  Andrew Ford  <a.ford@ford-mason.co.uk>
        * version 0.07
        * remove use of 'parent' in generated module
        * add handling of unmatched characters
        * add note about Unicode data that does not have the UTF8 flag set
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.