./print/ruby-pdf-core, PDF::Core is used by Prawn to render PDF documents

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.7.0, Package name: ruby23-pdf-core-0.7.0, Maintainer: pkgsrc-users

PDF::Core is used by Prawn to render PDF documents.


Required to run:
[lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: f5c070c4b6b1c0f531997e162e07cf06c904ad8d
RMD160: 85d856aea796f5cb05f400a35504672df06179c0
Filesize: 42 KB

Version history: (Expand)


CVS history: (Expand)


   2017-03-20 15:46:28 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-pdf-core to 0.7.0.

0.7.0							2017/3/11

* Breaking change: PDF::Core::PdfObject method has been renamed to
  PDF::Core::pdf_object
* Added support for horizontal scaling
* Added support for character spacing
* Added support for crops, bleeds, trims, and art box
   2016-03-15 15:59:59 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-pdf-core to 0.6.1.

Changes are not available.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-13 17:09:50 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-pdf-core to 0.6.0.

* Add spec for trailer initialization
* Update document state spec description
* Remove securerandom
* Fixed tests for document state trailer
* Remove default_trailer & leave it as an empty hash
* Add document ID to trailer for PDF-X spec compat
   2015-06-08 18:01:41 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Allow this package build on Ruby 2.2.
   2015-03-13 16:22:51 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-pdf-core to 0.5.1.

* Rename variable arr to array, fixes a call to an undefined variable b… elow.
* Round to four decimal places everywhere.
   2015-02-04 15:25:23 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update pdf-core to 0.4.0.  Although latest version is 0.5.0, latest
ruby-prawrn require prior to 0.5.

Changes are not available, please refer commit log on
<https://github.com/prawnpdf/pdf-core>.
   2014-04-17 22:25:48 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Requires Ruby 1.9.3.