./print/tex-glossaries, Create glossaries and lists of acronyms

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.33, Package name: tex-glossaries-4.33, Maintainer: pkgsrc-users

The glossaries package supports acronyms and multiple glossaries, and
has provision for operation in several languages (using the facilities
of either babel or polyglossia). New entries are defined to have a name
and description (and optionally an associated symbol). Support for
multiple languages is offered, and plural forms of terms may be
specified. An additional package, glossaries-accsupp, can make use of
the accsupp package mechanisms for accessibility support for PDF files
containing glossaries. The user may define new glossary styles, and
preambles and postambles can be specified. There is provision for
loading a database of terms, but only terms used in the text will be
added to the relevant glossary. The package uses an indexing program to
provide the actual glossary; either makeindex or xindy may serve this
purpose, and a Perl script is provided to serve as interface. The
package distribution also provides the mfirstuc package, for changing
the first letter of a word to upper case. The package supersedes the
author's glossary package (which is now obsolete), and a conversion tool
is provided.


Required to run:
[lang/perl5] [print/tex-xkeyval] [print/kpathsea] [print/tex-latex] [print/tex-tools] [print/tex-amsmath] [print/tex-oberdiek] [print/tex-xfor] [devel/tex-etoolbox]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)


Version history: (Expand)


CVS history: (Expand)


   2017-10-23 04:08:35 by Mark Davies | Files touched by this commit (6) | Package updated
Log message:
tex-glossaries{,-doc}: update to 4.33

- added package option nolangwarn
- added package option esclocations
- added \GlsSetXdyNumberGroupOrder
- added starred form of \GlsSetXdyFirstLetterAfterDigits
   2017-06-21 09:24:08 by Mark Davies | Files touched by this commit (52) | Package updated
Log message:
Update to TeXlive 2017

  Updated print/tex-glossaries{,-doc} to 4.30
  Updated print/tex-graphics{,-doc} to 1.2a
  Updated print/tex-graphics-def{,-doc} to 2017
  Updated graphics/tex-graphics-pln{,-doc} to 2017
  Updated print/tex-hausarbeit-jura{,-doc} to 1.5
  Updated print/tex-hyperref{,-doc} to 6.85a
  Updated print/tex-hyphen-base to 2017
  Updated print/tex-hyphen-german to 2017
  Updated print/tex-hyphen-latin to 3.1.2017
  Updated fonts/tex-inconsolata{,-doc} to 1.112
  Updated fonts/tex-ipaex-type1{,-doc} to 0.4a
  Updated fonts/tex-japanese-otf{,-doc} to 1.7b6.42950
  Updated print/tex-jsclasses to 2017
   2016-08-07 11:09:42 by Mark Davies | Files touched by this commit (123) | Package updated
Log message:
Update some texlive packages to latest versions.
Precise changes unknown
 Updated print/tex-amsmath(,-doc} to 2.15d
 Updated print/tex-caption(,-doc} to 20160522
 Updated print/tex-csplain to 2016.41764
 Updated print/tex-csquotes(,-doc} to 5.1h
 Updated print/tex-datatool(,-doc} to 2.27
 Updated print/tex-dvips(,-doc} to 2016.41704
 Updated print/tex-etex-pkg(,-doc} to 2.7
 Updated print/tex-glossaries(,-doc} to 4.25
 Updated print/tex-hyperref(,-doc} to 6.83q
 Updated print/tex-koma-script to 3.21
 Updated print/tex-latex(,-doc} to 2016.41765
 Updated print/tex-lollipop(,-doc} to 1.07
 Updated print/tex-luatex85(,-doc} to 1.4
 Updated print/tex-marginnote(,-doc} to 1.2
 Updated print/tex-media9(,-doc} to 0.69
 Updated print/tex-minted(,-doc} to 2.4
 Updated print/tex-musixtex(,-doc} to 1.23
 Updated print/tex-oberdiek(,-doc} to 2016.41346
 Updated print/tex-pdfcomment(,-doc} to 2.4
 Updated print/tex-ptex-base(,-doc} to 0.0.2016.41420
 Updated print/tex-readarray(,-doc} to 1.3
 Updated print/tex-showlabels(,-doc} to 1.8
 Updated print/tex-sttools(,-doc} to 1.9
 Updated print/tex-tex4ht(,-doc} to 2016.41726
 Updated print/tex-texinfo to 5.1.41792
 Updated print/tex-textpos(,-doc} to 1.8
 Updated print/tex-tools(,-doc} to 2016.41688
 Updated print/tex-toptesi(,-doc} to 5.92
 Updated print/tex-unicode-data(,-doc} to 1.5
 Updated print/tex-updmap-map to 2016.41585
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-09 09:59:23 by Mark Davies | Files touched by this commit (5) | Package updated
Log message:
Update tex-glossaries{,-doc} to 4.17

* makeglossaries (Perl script):

  - fixed ngerman din5007 issue.

* glossaries.sty:

  - new field-related commands:
    \glsaddstoragekey, \glsfielddef, \glsfieldedef,
    \glsfieldgdef, \glsfieldxdef, \glsfieldfetch,
    \ifglsfieldeq, \ifglsfielddefeq, \ifglsfieldcseq

  - new user command \glswriteentry to hook into mechanism
    that writes entry information to the external files

  - new user command \glspostlinkhook to hook into end of
    commands like \gls and \glstext.

  - Added new acronym styles "long-sp-short" and
    "long-sp-short-desc"

  - bug fix: \glsadd should use \@@do at wrglossary not
    \@do at wrglossary
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-04-23 00:42:18 by Mark Davies | Files touched by this commit (6) | Package updated
Log message:
Update tex-glossaries{,-doc} to 4.15

latest texlive version.  changes unknown.