./print/tex-texlive.infra, Basic TeX Live infrastructure

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2017, Package name: tex-texlive.infra-2017, Maintainer: minskim

This package contains the files needed to get the TeX Live tools
running.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)


Version history: (Expand)


CVS history: (Expand)


   2017-06-21 15:25:35 by Mark Davies | Files touched by this commit (99) | Package updated
Log message:
Update to TeXlive 2017

  Updated fonts/tex-raleway{,-doc} to 1.4
  Updated print/tex-readarray{,-doc} to 2.0
  Updated graphics/tex-repere{,-doc} to 17.05
  Updated fonts/tex-sansmathfonts{,-doc} to 2017
  Updated print/tex-siunitx{,-doc} to 2.7g
  Updated fonts/tex-sourcesanspro{,-doc} to 2.6
  Updated print/tex-sttools{,-doc} to 2.0
  Updated print/tex-tcolorbox{,-doc} to 4.03
  Updated print/tex-tetex{,-doc} to 3.0.44331
  Updated print/tex-tex4ht{,-doc} to 2017
  Updated print/tex-texconfig{,-doc} to 2017
  Updated print/tex-texdoc{,-doc} to 2017
  Updated print/tex-texinfo to 5.1.43137
  Updated print/tex-texlive.infra to 2017
  Updated print/tex-texlive-scripts to 2017
  Updated graphics/tex-tikzmark{,-doc} to 1.3
  Updated graphics/tex-tikzsymbols{,-doc} to 4.02
  Updated print/tex-todonotes{,-doc} to 1.0.5
  Updated print/tex-tools{,-doc} to 2017
  Updated print/tex-toptesi{,-doc} to 5.9.06
  Updated print/tex-udesoftec{,-doc} to 1.6.0
  Updated print/tex-updmap-map to 2017
  Updated fonts/tex-xcharter{,-doc} to 1.08
  Updated print/tex-xdvi to 22.87.03
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-09 13:15:49 by Mark Davies | Files touched by this commit (2) | Package updated
Log message:
Update tex-texlive.infra to 2015.37738

error handling changes.
   2015-06-14 14:50:07 by Mark Davies | Files touched by this commit (209) | Package updated
Log message:
Update to texlive 2015.

pdfTEX: Support JPEG Exif as well as JFIF; do not even emit a warning if
 \pdfinclusionerrorlevel is negative; sync with xpdf 3.04.
LuaTEX: New library newtokenlib for scanning tokens; bug fixes in the normal
 random number generator and other places.
XeTEX: Image handling fixes; xdvipdfmx binary looked for first as a sibling
 to xetex; internal XDV opcodes changed.
MetaPost: New numbersystem binary; new Japanese-enabled upmpost and
 updvitomp programs, analogous to up*tex.
Infrastructure: The fmtutil script has been reimplemented to read
 fmtutil.cnf on a per-tree basis, analogous to updmap. Web2C mktex* scripts
 (including mktexlsr, mktextfm, mktexpk) now prefer programs in their own
 directory, instead of always using the existing PATH.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-01-14 05:37:26 by Min Sik Kim | Files touched by this commit (3) | Package updated
Log message:
Update tex-texlive.infra to 2014

Documentation update for TeX Live 2014.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.