./print/xpdf-japanese, Xpdf support files for Japanese

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 20110902nb1, Package name: xpdf-japanese-20110902nb1, Maintainer: pkgsrc-users

This package provides support files needed to use the Xpdf tools with
Japanese PDF files.

Contents:
- Adobe-Japan1 character collection support
- ISO-2022-JP encoding
- EUC-JP encoding
- Shift-JIS encoding

DEINSTALL [+/-]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: d23a212a0a685d66ea1bf1748b1d7eee4907cc0c
RMD160: b5eba416652097b5a1ea347fa3890270a1e8f641
Filesize: 983.349 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-19 19:52:30 by Alistair G. Crooks | Files touched by this commit (352)
Log message:
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2014-12-17 00:37:48 by David A. Holland | Files touched by this commit (8) | Package updated
Log message:
Fix PLISTs after update. Reported by qjsgkem on freenode.
Bump PKGREVISIONS.
   2014-12-14 14:47:50 by Makoto Fujiwara | Files touched by this commit (22) | Package updated
Log message:
(pkgsrc)
  - Add LICENSE=       gnu-gpl-v2 OR gnu-gpl-v3
(upstream)
  - Update xpdf-* listed below
    from 2002-2005 to 20110815 or 20110902
(from)
             xpdf-arabic-20030216
 xpdf-chinese-simplified-20040727
xpdf-chinese-traditional-20040727
           xpdf-cyrillic-20030628
              xpdf-greek-20020628
             xpdf-hebrew-20030216
           xpdf-japanese-20040727
             xpdf-korean-20050707
             xpdf-latin2-20021022
               xpdf-thai-20020116
            xpdf-turkish-20020410
(to)
             xpdf-arabic-20110815
 xpdf-chinese-simplified-20110902
xpdf-chinese-traditional-20110902
           xpdf-cyrillic-20110815
              xpdf-greek-20110815
             xpdf-hebrew-20110815
           xpdf-japanese-20110902
             xpdf-korean-20110902
             xpdf-latin2-20110815
               xpdf-thai-20110815
            xpdf-turkish-20110815

Changes are stated in following file
   ftp://ftp.foolabs.com/pub/xpdf/CHANGES
The date and release numbers of xpdf are:
  3.01 (2005-aug-17)
  3.02 (2007-feb-27)
  3.03 (2011-aug-15)
   2012-10-08 15:45:50 by Aleksej Saushev | Files touched by this commit (147)
Log message:
Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.
   2010-01-27 16:14:01 by Joerg Sonnenberger | Files touched by this commit (33)
Log message:
Defer modification of xpdfrc to real package install time. Bump
revisions. Add DESTDIR support.
   2009-06-14 20:12:04 by Joerg Sonnenberger | Files touched by this commit (118)
Log message:
Remove @dirrm entries from PLISTs
   2006-03-14 02:14:36 by Johnny C. Lam | Files touched by this commit (134)
Log message:
Modify the pkginstall framework so that it manages all aspects of
INSTALL/DEINSTALL script creation within pkgsrc.

If an INSTALL or DEINSTALL script is found in the package directory,
it is automatically used as a template for the pkginstall-generated
scripts.  If instead, they should be used simply as the full scripts,
then the package Makefile should set INSTALL_SRC or DEINSTALL_SRC
explicitly, e.g.:

	INSTALL_SRC=	${PKGDIR}/INSTALL
	DEINSTALL_SRC=	# emtpy

As part of the restructuring of the pkginstall framework internals,
we now *always* generate temporary INSTALL or DEINSTALL scripts.  By
comparing these temporary scripts with minimal INSTALL/DEINSTALL
scripts formed from only the base templates, we determine whether or
not the INSTALL/DEINSTALL scripts are actually needed by the package
(see the generate-install-scripts target in bsd.pkginstall.mk).

In addition, more variables in the framework have been made private.
The *_EXTRA_TMPL variables have been renamed to *_TEMPLATE, which are
more sensible names given the very few exported variables in this
framework.  The only public variables relating to the templates are:

	INSTALL_SRC		INSTALL_TEMPLATE
	DEINSTALL_SRC		DEINSTALL_TEMPLATE
				HEADER_TEMPLATE

The packages in pkgsrc have been modified to reflect the changes in
the pkginstall framework.