./security/kpcli, Command line interface to KeePass password safes

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.0nb2, Package name: kpcli-3.0nb2, Maintainer: pkgsrc-users

A command line interface (interactive shell) to work with KeePass
1.x and 2.x database files.


Required to run:
[security/p5-Crypt-Rijndael] [devel/p5-Clone] [devel/p5-Term-ReadKey] [devel/p5-Term-ShellUI] [devel/p5-Term-ReadLine-Perl] [devel/p5-Sort-Naturally]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: b2861d243b8d4bbb15005fcf6dc33212f5f821c4
RMD160: d12da6eb69a58ed185f962e622225d0f5705414c
Filesize: 177.579 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-12-11 14:17:10 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update kpcli to 3.0.

 2015-Feb-08 v2.8 - Fixed cli_copy bug; refresh paths and ask to save.
                    Fixed a cli_mv bug; double path-normalization.
                    Fixed a path display bug, if done after a cli_mv.
                    Protect users from editing in the $FOUND_DIR.
                    Keep file opened, read-only, to show up in lsof.
                    Added inactivity locking (--timeout parameter).
                    Added shell expansion support to cli_ls, with the
                     ability to manage _all_ listed entries by number.
                    Added shell expansion support to cli_mv.
                    Added [y/N] option to list entries after a find.
 2015-Jun-19 v3.0 - Added Password Safe v3 file importing; requires
                     optional Crypt::PWSafe3 from CPAN.
                    Added $FORCED_READLINE global variable.
                    Attachments sanity check; SourceForge bug #17.
                    Endianness fix in magic_file_type(); SF bug #19.
   2015-11-04 02:18:12 by Alistair G. Crooks | Files touched by this commit (434)
Log message:
Add SHA512 digests for distfiles for security category

Problems found locating distfiles:
	Package f-prot-antivirus6-fs-bin: missing distfile fp-NetBSD.x86.32-fs-6.2.3.tar.gz
	Package f-prot-antivirus6-ws-bin: missing distfile fp-NetBSD.x86.32-ws-6.2.3.tar.gz
	Package libidea: missing distfile libidea-0.8.2b.tar.gz
	Package openssh: missing distfile openssh-7.1p1-hpn-20150822.diff.bz2
	Package uvscan: missing distfile vlp4510e.tar.Z

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-08-28 10:47:52 by Thomas Klausner | Files touched by this commit (1) | Package updated
Log message:
Add missing dependency on p5-Clone. Bump PKGREVISION.
   2014-07-05 07:17:27 by Thomas Klausner | Files touched by this commit (1) | Package updated
Log message:
Add dependency on p5-Term-ReadLine-Perl. Either that or
...-Gnu is needed for kpcli to work.
Bump PKGREVISION.