./security/p5-GnuPG-Interface, Perl interface to GnuPG

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.52nb2, Package name: p5-GnuPG-Interface-0.52nb2, Maintainer: pkgsrc-users

GnuPG::Interface and its associated modules are designed to provide an
object-oriented method for interacting with GnuPG, being able to perform
functions such as but not limited to encrypting, signing, decryption,
verification, and key-listing parsing.


Required to run:
[lang/perl5] [security/gnupg] [devel/p5-Moo] [devel/p5-MooX-HandlesVia] [devel/p5-MooX-late]

Master sites: (Expand)

SHA1: cb3ae8479edf668d88d7dd90c08036ceb79bbfa7
RMD160: 1fc947172288205893642bace958fad3e6c34c6f
Filesize: 62.239 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-04 02:18:12 by Alistair G. Crooks | Files touched by this commit (434)
Log message:
Add SHA512 digests for distfiles for security category

Problems found locating distfiles:
	Package f-prot-antivirus6-fs-bin: missing distfile fp-NetBSD.x86.32-fs-6.2.3.tar.gz
	Package f-prot-antivirus6-ws-bin: missing distfile fp-NetBSD.x86.32-ws-6.2.3.tar.gz
	Package libidea: missing distfile libidea-0.8.2b.tar.gz
	Package openssh: missing distfile openssh-7.1p1-hpn-20150822.diff.bz2
	Package uvscan: missing distfile vlp4510e.tar.Z

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-02-19 14:18:10 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 0.52:

0.52 - 2016-02-16
 - Skip "grp" records, generated by GPG 2.1; this suppresses "unknown
   record type" warnings
 - Add explicit Fatal dependency; though nominally part of code perl,
   RedHat's perl does not ship with it
 - Ensure that the trustdb is created before attempting to encrypt; gpg2
   requires that it exist, even for commands with --trust-model=always.
   See https://bugs.debian.org/cgi-bin/bugrepo … bug=751266
   2014-12-30 14:04:04 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 0.51:

0.51 - 2014-12-17
 - Update README file
 - Work around gpg2 bug by omitting --homedir during symmetric
   encryption
   2014-09-06 16:24:04 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 0.50:

0.50 - 2014-03-14
 - Version 0.49 implicitly required Moose; switch to a technique that
   does not
 - Modernize CHANGES

0.49 - 2014-03-13
 - Restore context-sensitive (array/arrayref) behavior of multiple array
   methods from 0.46.
 - Fix MANIFEST/.gitignore inconsistency

0.48 - 2014-03-10
 - Switch from --always-trust to --trust-model=always

0.47 - 2014-03-10
 - No changes from 0.47_02

0.47_02 - 2014-02-14
 - Remove a stray 'use Data::Dumper::Concise' added in 0.47_01

0.47_01 - 2014-01-27
 - Switch from Any::Moose to Moo
 - Accept "gpg (GnuPG/MacGPG2)" as a valid gpg version
 - Typo fixes in documentation
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-06-01 09:34:58 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 0.46:

0.46 Thu Oct 25 14:04:17 EDT 2012

	Add a ->search_keys method
	Add a ->version method
	Remove dead code for finding gnupg2 binary