./security/py-ntlm-auth, NTLM authentication handler for python-requests

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.2.0, Package name: py27-ntlm-auth-1.2.0, Maintainer: pkgsrc-users

This library handles the low-level details of NTLM authentication for use
in authenticating with a service that uses NTLM. It will create and parse
the 3 different message types in the order required and produce a base64
encoded value that can be attached to the HTTP header.

Features:
- LM, NTLM and NTLMv2 authentication
- NTLM1 and NTLM2 extended session security
- Set the The NTLM Compatibility level when sending messages
- Channel Binding Tokens support, need to pass in the SHA256 hash of the
certificate for it to work
- Support for MIC to enhance the integrity of the messages
- Support for session security with signing and sealing messages after
authentication happens


Required to run:
[devel/py-setuptools] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: ab4abe0e040a8eaada36e0dd1791f99fc760e4c3
RMD160: 11dbc5497f83ba9bf5d6fe765ade7391c60a18bf
Filesize: 24.251 KB

Version history: (Expand)


CVS history: (Expand)


   2018-07-06 09:52:40 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-ntlm-auth: updated to 1.2.0

1.2.0:
Deprecated ntlm_auth.ntlm.Ntlm in favour of ntlm_auth.ntlm.NtlmContext
This is because Ntlm is heavily geared towards HTTP auth which is not always the \ 
case, NtlmContext makes things more generic
Updated docs and tests to reflect this
Dropped support for Python 3.3
   2018-03-08 13:45:34 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-ntlm-auth: updated to 1.1.0

1.1.0:
Removed DES code as the license was found to be incorrect from the source
Added new DES code not based on the original
Fixed up some deprecation warnings
Changed tests from running unittest to py.test
Changed licence from GPL to MIT as code is not all my own
   2017-10-31 09:27:03 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-ntlm-auth: updated to 1.0.6

Changes 1.0.6:
* More changes to packaging to better handle copyright and licensing
   2017-09-04 20:57:20 by Joerg Sonnenberger | Files touched by this commit (4)
Log message:
Add py-ntlm-auth-1.0.5:

This library handles the low-level details of NTLM authentication for use
in authenticating with a service that uses NTLM. It will create and parse
the 3 different message types in the order required and produce a base64
encoded value that can be attached to the HTTP header.

Features:
- LM, NTLM and NTLMv2 authentication
- NTLM1 and NTLM2 extended session security
- Set the The NTLM Compatibility level when sending messages
- Channel Binding Tokens support, need to pass in the SHA256 hash of the
  certificate for it to work
- Support for MIC to enhance the integrity of the messages
- Support for session security with signing and sealing messages after
  authentication happens