./security/starttls, Simple wrapper program for STARTTLS on emacsen

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.10nb9, Package name: starttls-0.10nb9, Maintainer: cheusov

Simple wrapper program for STARTTLS on emacsen.


Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: bf2074d047474ef33f5da9924f6fd52a119dc578
RMD160: ad9c3bc690dd1bf11f4f173edf05b2f2eaff1275
Filesize: 65.718 KB

Version history: (Expand)


CVS history: (Expand)


   2016-03-05 12:29:49 by Jonathan Perkin | Files touched by this commit (1813) | Package updated
Log message:
Bump PKGREVISION for security/openssl ABI bump.
   2015-11-04 02:18:12 by Alistair G. Crooks | Files touched by this commit (434)
Log message:
Add SHA512 digests for distfiles for security category

Problems found locating distfiles:
	Package f-prot-antivirus6-fs-bin: missing distfile fp-NetBSD.x86.32-fs-6.2.3.tar.gz
	Package f-prot-antivirus6-ws-bin: missing distfile fp-NetBSD.x86.32-ws-6.2.3.tar.gz
	Package libidea: missing distfile libidea-0.8.2b.tar.gz
	Package openssh: missing distfile openssh-7.1p1-hpn-20150822.diff.bz2
	Package uvscan: missing distfile vlp4510e.tar.Z

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2014-02-13 00:18:57 by Matthias Scheler | Files touched by this commit (1568)
Log message:
Recursive PKGREVISION bump for OpenSSL API version bump.
   2013-02-07 00:24:19 by Jonathan Perkin | Files touched by this commit (1351) | Package updated
Log message:
PKGREVISION bumps for the security/openssl 1.0.1d update.
   2012-10-23 20:17:02 by Aleksej Saushev | Files touched by this commit (368)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2012-09-14 15:20:23 by Aleksey Cheusov | Files touched by this commit (1)
Log message:
Remove emacs from dependencies because it may be used
by other programs. One example is ssmtp. ++pkgrevision
   2012-07-18 01:19:19 by Aleksey Cheusov | Files touched by this commit (1)
Log message:
Take maintainership. FUKAUMI Naoki didn't object.
   2012-07-17 20:08:03 by Aleksey Cheusov | Files touched by this commit (2)
Log message:
starttls.{el,elc} files are not provided by the package anymore. The problem
is starttls's implementation is incompatible with emacs 22, 23 and probably
24 too, as a result sending emails with ssl/tls authorization fail due to
this
conflict.  emacs-21 has its own starttls.el too and I believe it is also
sufficient. I wonder if someone still uses emacs-20 and its smtpmail.el for
sending emails. This change was tested on NetBSD-6 and emacs-{22,23}.

starttls package now DEPENDS on emacs-[0-9]*, that is any emacs flavour is
good enough

Set LICENSE to gnu-gpl-v2

++pkgrevision