./sysutils/ruby-rb-appscript, Ruby Apple event bridge

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.6.1nb1, Package name: ruby23-rb-appscript-0.6.1nb1, Maintainer: pkgsrc-users

Ruby appscript (rb-appscript) is a high-level, user-friendly Apple
event bridge that allows you to control scriptable Mac OS X
applications using ordinary Ruby scripts.


Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: d5576c0ab3d14f8270aac5304bcd151a81292e5b
RMD160: 9148020831582e815c3c5ab68c53ca70df9e3209
Filesize: 218 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-04 02:32:42 by Alistair G. Crooks | Files touched by this commit (499)
Log message:
Add SHA512 digests for distfiles for sysutils category

Problems found with existing digests:
	Package memconf distfile memconf-2.16/memconf.gz
	b6f4b736cac388dddc5070670351cf7262aba048 [recorded]
	95748686a5ad8144232f4d4abc9bf052721a196f [calculated]

Problems found locating distfiles:
	Package dc-tools: missing distfile dc-tools/abs0-dc-burn-netbsd-1.5-0-gae55ec9
	Package ipw-firmware: missing distfile ipw2100-fw-1.2.tgz
	Package iwi-firmware: missing distfile ipw2200-fw-2.3.tgz
	Package nvnet: missing distfile nvnet-netbsd-src-20050620.tgz
	Package syslog-ng: missing distfile syslog-ng-3.7.2.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-27 01:40:30 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Update HOMEPAGE.
Avoid using rubyforge.org since it stopped most of services.
   2015-03-08 16:17:22 by Takahiro Kambe | Files touched by this commit (58) | Package updated
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete for new rubygems and updated ruby.
   2014-03-17 15:30:38 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add GEM_EXTSDIR support.
   2013-10-01 17:24:02 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Fix build problem and clean up PLIST.

Bump PKGREVISION.
   2012-04-27 12:30:41 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update sysutils/ruby-rb-appscript to 0.6.1.

2010-03-19 -- 0.6.1

* removed 32-bit only AE.run_application_event_loop,
  AE.quit_application_event_loop
* updated AE.launch_application to use LSOpenApplication
* minor documentation fixes

2010-12-17 -- 0.6.0

* added UTF-8 Encoding support in Ruby 1.9+; added
  AEMCodecs::Codecs#use_ascii_8bit for optionally disabling it
* AEM::Codecs#pack now accepts Date, DateTime instances; added
  AEM::Codecs#use_date_time method for unpacking typeLongDateTime descriptors
  as DateTime instead of Time instances
* removed AE.get_app_terminology() as it relied on deprecated Carbon APIs
* added AE.copy_scripting_definition()
* the OSAX module now now uses OSACopyScriptingDefinition() to obtain
  scripting addition terminology, so works in both 32- and 64-bit Ruby. Note
  that in addition to limitations of OSACopyScriptingDefinition
  (e.g. aete-to-sdef conversion is not 100% reliable), the SdefParser is
  limited in capability (no support for xi:include, class-extension, synonym
  elements), but should suffice for parsing relatively simple osax
  dictionaries.
* modified Terminology.dump() to retrieve aete resources via 'ascrgdte'
  events; added OSAX.dump() method
* added workaround for transaction id bug in some versions of OS X 10.6
* renamed AEMReference::Base class to AEMReference::Query
* renamed Send::CommandError class to Send::EventError; note that AEM
  re-exports it as AEM::EventError and [for backwards compatibilty]
  AEM::CommandError

2009-07-18 -- 0.5.3

* fixed pALL code in defaultterminology
* fixed OSAX module initialisation code (previously didn't initialise if
  ScriptingAddition.new was called directly)
* fixed out-of-date URLs in appscript manual

2009-07-05 -- 0.5.2

* removed deprecated AEM::Application.is_running? method
* added #dont_cache_unpacked_specifiers, #pack_strings_as_type compatibility
  options to AEM::Codecs
* added default definitions for 'item' type, 'items' elements, 'properties'
  property as Apple have removed the 'item' class definition from
  skeleton.sdef (the default terminology for Cocoa apps)
* property and elements methods now raise ArgumentError if passed arguments;
  previously, malformed elements selectors,
  e.g. app('TextEdit').documents(1).text, would be silently ignored, resulting
  in unexpected behaviour
* Codecs#unpack now tries to coerce descriptors of typeVersion to unicode text
  (works on 10.4+) c.f. AppleScript (note: itunes.version.get returns the
  wrong version number otherwise; this appears to be an iTunes bug, but is
  masked by current AppleScript behaviour)
* #process_exists_for_url?, #remote_app in connect.rb now raise error if URL
   string doesn't contain a colon (process will crash otherwise due to an OS
   bug)
* improved error reporting in Reference#[] when a malformed generic reference
  containing a command expands to a non-reference value. e.g. its.name.get()
  would previously expand the the value of the object's 'name' property,
  typically a string, resulting in a cryptic NoMethodError; this now raises a
  descriptive ArgumentError.
* fixed bug where Terminology module would error on zero-length keywords in
  problem dictionaries (e.g. MS Word 12.1.7)
* AEM::Codecs now correctly unpacks AEDescs of typeBoolean whose data >1 byte
* fixed inconsistent escaping of application-defined property/element names
  that overlap built-in type/enum/property names but uses different
  codes. e.g. Adobe Illustrator defines 'rotation' as 'SxRx' - this overlaps
  built-in definition ('rotation' = 'trot'), so is escaped as
  'rotation_'. Previously only the Keyword was escaped (i.e. :rotation_ but
  ref.rotation) now both are escaped (i.e. :rotation_, ref.rotation_). Users
  should update existing code as needed.
* restructured defaultterminology.rb to make it easier to maintain
* changed default terminology mapping for :data from KAE::CRawData ('rdat') to
  KAE::TypeData ('tdta')
* the OSAX module now obtains list of installed scripting additions on first
  use instead of import (the .osax scanning code uses System Events via AEM,
  and sending Apple events in event loop-based application before the event
  loop is started can disrupt the process's handling of incoming Apple events)
   2010-09-10 09:59:30 by Takahiro Kambe | Files touched by this commit (1)
Log message:
* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Remove default value of GEM_BUILD.
   2009-06-14 23:28:48 by Joerg Sonnenberger | Files touched by this commit (22)
Log message:
Convert @exec/@unexec to @pkgdir or drop it.