./sysutils/xenkernel48, Xen 4.8.x Kernel

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.8.3nb1, Package name: xenkernel48-4.8.3nb1, Maintainer: bouyer

Xen is a hypervisor which supports running multiple guest operating
systems on a single machine. Guest OSes (also called "domains")
can be either paravirtualised (i.e. make hypercalls in order to
access hardware), run in HVM (Hardware Virtualisation Mode) where
they will be presented with virtual devices, or a combination where
they use hypercalls to access hardware but manage memory themselves.
At boot, the xen kernel is loaded along with the guest kernel for
the first domain (called domain0). domain0 has privileges to access
the physical hardware (PCI and ISA devices), administrate other
domains and provide virtual devices (disks and network) to other
domains.

This package contains the 4.8 Xen kernel itself. PCI passthrough is
not supported. PAE is mandatory; on i386 one must use XEN3PAE_DOM[0U].


Required to build:
[lang/python27] [pkgtools/cwrappers]

Master sites:


Version history: (Expand)


CVS history: (Expand)


   2019-07-15 18:24:18 by Nia Alarie | Files touched by this commit (8)
Log message:
Use https for xenproject.org.
   2019-04-25 09:33:32 by Maya Rashish | Files touched by this commit (620)
Log message:
PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.
   2018-07-24 19:29:09 by Maya Rashish | Files touched by this commit (10)
Log message:
sysutils/xen*: invert python version logic, only 2.7 is ok.

Mostly so we don't match python37 on xen 4.11, but also because python3
is a moving target and this saves us having to add the next version.
   2018-07-03 07:03:44 by Adam Ciarcinski | Files touched by this commit (495)
Log message:
extend PYTHON_VERSIONS_ for Python 3.7
   2018-01-25 00:29:33 by Manuel Bouyer | Files touched by this commit (27) | Package removed
Log message:
Update xen 4.8 packages to 4.8.3. Changes since 4.8.2: include patches from
all security advisory up to and including XSA254.

While there pass XEN_VENDORVERSION=nb${PKGREVISION} to make so that
'xl info' shows the NetBSD PKGREVISION. If PKGREVISION is not available,
define this as 'nb0'.
   2018-01-18 11:28:13 by Manuel Bouyer | Files touched by this commit (6) | Package updated
Log message:
Add patches from upstream, from xsa254/README.pti :
> This README gives references for one of three mitigation strategies
> for Meltdown.

> This series is a first-class migitation pagetable isolation series for
> Xen.  It is available for Xen 4.6 to Xen 4.10 and later.

bump PKGREVISION
   2018-01-15 10:47:55 by Jonathan Perkin | Files touched by this commit (8)
Log message:
xen*: Use SSP_SUPPORTED=no instead of PKGSRC_USE_SSP=no.
   2017-12-15 15:02:15 by Manuel Bouyer | Files touched by this commit (11) | Package updated
Log message:
Apply patches from upstream, fixing security issues XSA246 up to XSA251.
Also update patch-XSA240 from upstream, fixing issues in linear page table
handling introduced by the original XSA240 patch.
Bump PKGREVISION