./textproc/p5-Text-Xslate, Scalable template engine for Perl5

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.4.0nb1, Package name: p5-Text-Xslate-3.4.0nb1, Maintainer: pkgsrc-users

Xslate is a template engine, tuned for persistent applications, safe
as an HTML generator, and with rich features.


Required to run:
[sysutils/p5-File-Copy-Recursive] [lang/perl5] [devel/p5-Mouse] [devel/p5-Test-LeakTrace] [devel/p5-Test-Requires] [devel/p5-Data-MessagePack]

Master sites: (Expand)

SHA1: 5d6c60c09651dda855975b9db94211abf1d76fd8
RMD160: e7c14adde81280991584bc0230911df8dff00089
Filesize: 223.521 KB

Version history: (Expand)


CVS history: (Expand)


   2017-08-23 19:54:53 by Johnny C. Lam | Files touched by this commit (4)
Log message:
Add PERL_USE_UNSAFE_INC=1 to a few Perl module Makefiles.

The following packages fail to build due to "." not being in @INC:

    devel/p5-PPI-PowerToys
    sysutils/p5-Monitoring-Plugin
    textproc/p5-Text-Xslate
    www/SpeedyCGI

Pass PERL_USE_UNSAFE_INC=1 through MAKE_ENV to allow the configure
and build to proceed.

This needs to be revisited when perl-5.30.0 is released and that
environment variable is removed from Perl.
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-01-24 02:48:25 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 3.4.0

Upstream changes:
3.4.0 2017-01-20 15:00:00+0900
    - Fix tied hash issue(#173)
    - Fix encoding issue(#160)
    - Fix segmentation fault issue by accessing uninitialized array element(#159)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-12-31 13:21:03 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 3.3.9

Upstream changes:
3.3.9 2015-12-18 22:15:00+0900
    - Fix test for Windows
      3.3.8 change breaks Windows

3.3.8 2015-12-18 16:20:00+0900
    - Fix test for DragonflyBSD
    - Update document
   2015-11-04 03:00:17 by Alistair G. Crooks | Files touched by this commit (797)
Log message:
Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-29 05:44:07 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 3.3.7
Update DEPENDS

Upstream changes:
3.3.7 2015-08-28 13:45:00+0900
    - Fix for older Perl 5.8.8 or lower(#145)
    - Enable 5.8 tests again

3.3.6 2015-08-25 13:50:00+0900
    - Fix issue 'include' makes stack pointer incorrect(#130)

3.3.5 2015-08-05 18:50:00+0900
    - Update Mouse version for Perl 5.22 or higher
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg