./textproc/p5-XML-Encoding, Perl module for parsing XML encoding maps

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.09nb3, Package name: p5-XML-Encoding-2.09nb3, Maintainer: pkgsrc-users

This module, which is built as a subclass of XML::Parser, provides a parser
for encoding map files, which are XML files. The file maps/encmap.dtd in the
distribution describes the structure of these files. Calling a parse method
returns the name of the encoding map (obtained from the name attribute of the
root element). The contents of the map are processed through the callback
functions push_prefix, pop_prefix, and range_set.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: ccf6f97d2a4c4ada990d5f75d71f014cd756aac5
RMD160: 3d03f63b1463daaa4028de6bcb39c2c335100a61
Filesize: 183.766 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-05-03 12:54:58 by Thomas Klausner | Files touched by this commit (78)
Log message:
Reset maintainer (observer now).
   2015-11-04 03:00:17 by Alistair G. Crooks | Files touched by this commit (797)
Log message:
Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-09-06 16:07:36 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 2.09

Upstream changes:
2.09 30 May 2014
        - Uploaded source code to GitHub and included repository URLs in
          metadata.
        - Included META.json file in addition to META.yml.
        - Set minimum required ExtUtils::MakeMaker version to 6.64 to ensure
          that all parameters used are supported, to save jumping through hoops
          to support earlier versions.  (This should not be a problem since
          ExtUtils::MakeMaker 6.64 is easily installed into Perl 5.8.1 and
          above, that being the whole point of the new choice of minimum
          supported Perl version.)
        - Set minimum required Perl version to 5.8.1.  This is in line with the
          minimum requirement of the "Perl Toolchain".
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.