./textproc/p5-XML-Rabbit, Perl 5 module to consume XML with Moose and xpath queries

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.4.1nb2, Package name: p5-XML-Rabbit-0.4.1nb2, Maintainer: pkgsrc-users

The Perl 5 module XML::Rabbit is a simple Moose-based base class
you can use to make simple XPath-based XML extractors. Each attribute
in your class is linked to an XPath query that is executed on your
XML document when you request the value.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: dafaecd577beca327b2e270a95dcac83fd0ea5dc
RMD160: 7457f515acf14fc65ece6ecfed1b3fc8e3215e85
Filesize: 54.818 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-02-27 04:04:11 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.4.1

Upstream changes:
0.4.1     2015-09-18 15:45:02+02:00 Europe/Oslo
        Replaced Class::MOP::class_of() calls with Moose::Util::find_meta().
        Added huge => 1 parameter to LibXML DOM parser, to support large
          text nodes.
   2015-11-04 03:00:17 by Alistair G. Crooks | Files touched by this commit (797)
Log message:
Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2014-05-03 16:13:06 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.4.0

Upstream changes:
0.4.0     2013-11-29 11:18:57 Europe/Oslo
        Fixed RT#90975 (reported by Upasana Shukla)
            Replaced deprecated Class::MOP::load_class() with
            Class::Load::load_class(). Module::Runtime::require_module()
            couldn't be used because of tests with package definitions in
            BEGIN blocks.
   2013-08-24 04:17:01 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.3.0

Upstream changes:
0.3.0     2013-03-15 15:24:53 Europe/Oslo
        Gotten rid of Data::Visitor::Callback used to parse type
          constraints. Reported by Alceu Rodrigues de Freitas Junior
          (RT #81753). Solution contributed by chromatic.