./textproc/ruby-bluecloth, Markdown library for Ruby

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.2.0, Package name: ruby23-bluecloth-2.2.0, Maintainer: pkgsrc-users

BlueCloth is a Ruby implementation of Markdown, a text-to-HTML conversion
tool for web writers. Markdown allows you to write using an easy-to-read,
easy-to-write plain text format, then convert it to structurally valid
XHTML (or HTML).


Required to run:
[lang/ruby23-base]

Master sites:

SHA1: 9c1ba2ea217c051d81fbf8e29ef83aa96d53f9da
RMD160: 095564d3f162860bfc54d46d6331870d4c3e51ca
Filesize: 92 KB

Version history: (Expand)


CVS history: (Expand)


   2017-09-04 20:08:31 by Thomas Klausner | Files touched by this commit (163)
Log message:
Follow some redirects.
   2017-09-04 20:01:05 by Thomas Klausner | Files touched by this commit (192)
Log message:
Comment out dead sites.
   2015-11-04 03:00:17 by Alistair G. Crooks | Files touched by this commit (797)
Log message:
Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-03-08 16:17:22 by Takahiro Kambe | Files touched by this commit (58) | Package updated
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete for new rubygems and updated ruby.
   2014-03-17 15:31:35 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add GEM_EXTSDIR support.
   2014-03-13 12:08:54 by Jonathan Perkin | Files touched by this commit (67)
Log message:
Set USE_GCC_RUNTIME=yes for packages which build shared libraries but do
not use libtool to do so.  This is required to correctly depend upon a
gcc runtime package (e.g. gcc47-libs) when using USE_PKGSRC_GCC_RUNTIME.
   2011-12-15 16:59:34 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-bluecloth package to 2.2.0.

== v2.2.0 [2011-11-01] Michael Granger <ged@FaerieMUD.org>

- Config -> RbConfig (1.9.3 deprecation fix)
- Adding a manpage for bin/bluecloth for packagers that require every
  binary have one (e.g., Debian) (fixes #78). Thanks to Cédric
  Boutillier for the contribution.
- Updated for Discount 2.0.9
   2011-06-19 05:35:06 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-bluecloth pacakge to 2.1.0.

Not complete but from History.md:

## 2.0.11 [2011-02-10] Michael Granger <ged@FaerieMUD.org>

Enhancements:

* gem-testers support
* Update to Discount 2.0.5

Bugfixes:

* Removed unnecessary requires from top-level file
* Fix for Windows devkit installs

## v2.0.10 [2011-02-09] Michael Granger <ged@FaerieMUD.org>

Enhancements:

Updated to Discount 2.0.4:
* Added configuration options for all of Discount's extensions.
* Worked around a Discount bug when rendering the same document twice (appends a \0)