./textproc/ruby-redcloth, Textile library for Ruby

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.3.2, Package name: ruby23-redcloth-4.3.2, Maintainer: pkgsrc-users

RedCloth is a Ruby library for working with the Textile language
(http://www.textism.com/tools/textile/).


Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 911660419e167a964756181875bd74407ec3deec
RMD160: 4448e243f00b476ec8a9795b22fa2270443bff05
Filesize: 228 KB

Version history: (Expand)


CVS history: (Expand)


   2016-10-18 16:43:14 by Takahiro Kambe | Files touched by this commit (4) | Package updated
Log message:
Update ruby-redcloth to 4.3.2.

pkgsrc change: Add support for pkg_alternatives.

== 4.3.2 / May 23rd, 2016

* Fix additional case for CVE-2012-6684 [Joshua Siler]

== 4.3.1 / May 17th, 2016

* Fix additional case for CVE-2012-6684 [Joshua Siler]

== 4.3.0 / April 29th, 2016

* Remove JRuby and Windows cross compilation and support
* Add Ruby 2.2.3 testing and support

* include CVE-2012-6684 fix [Tomas Pospisek]
  * fix by [Antonio Terceiro]
    * see \ 
http://sources.debian.net/src/ruby-redc … l-o.patch/
  * vulnerability reported by [Kousuke Ebihara]
    * see http://co3k.org/blog/redcloth-unfixed-xss-en

== 4.2.9.1 / February 24, 2015

* Lazy-load latex_entities.yml [Charlie Somerville]
   2015-11-04 03:00:17 by Alistair G. Crooks | Files touched by this commit (797)
Log message:
Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-03-08 16:17:22 by Takahiro Kambe | Files touched by this commit (58) | Package updated
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete for new rubygems and updated ruby.
   2014-03-17 15:34:33 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add GEM_EXTSDIR support.
   2014-03-13 12:08:54 by Jonathan Perkin | Files touched by this commit (67)
Log message:
Set USE_GCC_RUNTIME=yes for packages which build shared libraries but do
not use libtool to do so.  This is required to correctly depend upon a
gcc runtime package (e.g. gcc47-libs) when using USE_PKGSRC_GCC_RUNTIME.
   2011-12-15 17:19:33 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-redcloth package to 4.2.9.

== 4.2.9 / November 25, 2011

* Fix RbConfig / Config warning in Ruby 1.9.3. [Steve Purcell, Robert Gleeson, \ 
and unclaimedbaggage]
* Use RSTRING_NOT_MODIFIED header for Rubinius [Dirkjan Bussink]
   2011-11-08 16:37:35 by Takahiro Kambe | Files touched by this commit (32) | Package updated
Log message:
* Remove .require_paths from PLIST
* Bump PKGREVISION.
   2011-06-19 05:39:05 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-redcloth package to 4.2.7.

== 4.2.7 / Febrary 10, 2011

* Fixed typo in gemspec to make case-sensitive require work. [Gabe da Silveira]
* Tested installing the gem and requiring it with both cases on Ubuntu 8.04, \ 
10.10 and OS X Version 10.6.6.
* Have spaces around the en-dash in LaTeX [Benjamin Quorning]
* Turned double-quote close to smart quotes in LaTeX [Jonathan D. Blake]

=== 4.2.6 / February 9, 2011

* Add case-sensitive require back into the gemspec.
* Fix rdoc options in gemspec.

=== 4.2.5 / February 7, 2011

* Fix bundler and rubygems-test incompatibilities. Working around bug:
    https://github.com/carlhuda/bundler/issues/issue/1021

=== 4.2.4 / February 7, 2011

* Add .gemtest to opt-in to rubygems-test program (gem install rubygems-test to \ 
participate)
* Allow attributes to be set on hr and br tags [Jesse Stormier]
* Fix dangling <li> [Stephen Bannasch]
* Switch to bundler and rake-compiler for gem management/compilation
* Fix invalid YAML for Ruby 1.9.2 [Aaron Patterson]