./time/p5-DateTime-Locale, Localization data for p5-DateTime

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.14, Package name: p5-DateTime-Locale-1.14, Maintainer: pkgsrc-users

The DateTime::Locale modules provide localization data for the DateTime.pm
class.


Required to run:
[lang/perl5] [devel/p5-Scalar-List-Utils] [devel/p5-namespace-autoclean] [devel/p5-Dist-CheckConflicts] [devel/p5-Params-ValidationCompiler] [devel/p5-Specio]

Required to build:
[devel/p5-Exception-Class] [devel/p5-Test-Requires] [devel/p5-CPAN-Meta-Check] [devel/p5-Test-Warnings] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: a8834fec68c5ef4362e1a37cc118c03a35c944b7
RMD160: d1f72b592c7e711a511e331233c35a282c12f5a3
Filesize: 1000.221 KB

Version history: (Expand)


CVS history: (Expand)


   2017-03-08 12:49:45 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-DateTime-Locale to 1.14.

1.14     2017-03-05

- Codes with just a language and script code were not parsed correctly,
  leading to bugs in their data, so that they did not report a script_code,
  nor did their name reflect the script. So for example "bs-Latn" was just
  "Bosnian" instead of "Bosnian Latin".

1.13     2017-03-05

- Fixed a regression bug where providing a locale's English name or native
  name to DateTime::Locale->load no longer worked. Fixed by Sergey. GH #13.
   2017-01-30 02:54:48 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.12

Upstream changes:
1.12     2017-01-29

- Rebuilt all locale data with CLDR 30.0.3, released on 2016-12-02.
   2016-11-16 11:17:55 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-DateTime-Locale to 1.11.

1.11     2016-11-12

- Switched from RT to the GitHub issue tracker.
   2016-10-28 11:45:37 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-DateTime-Locale to 1.10.

1.10     2016-10-22

- Don't let warnings from other modules cause t/09version-check.t to
  fail. Reported by Graham Ollis. RT #118465
   2016-10-18 10:26:55 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-DateTime-Locale to 1.09.

1.09     2016-10-10

- Rebuilt all locale data with CLDR 30, released on 2016-10-05.
   2016-09-30 13:02:56 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-DateTime-Locale to 1.08.

1.08     2016-09-23

- Require namespace::autoclean 0.19+.
   2016-09-19 01:38:25 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated time/p5-DateTime-Locale to 1.07
---------------------------------------
1.07     2016-09-17
- Bump minimum required Perl to 5.8.4 from 5.8.1. This matches DateTime.pm
  itself.
   2016-09-18 16:59:25 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated time/p5-DateTime-Locale to 1.06
---------------------------------------
1.06     2016-09-16
- Replaced Params::Validate with Params::ValidationCompiler.

(pkgsrc changes)
- for runtime:
  -DEPENDS+= p5-Params-Validate>=0.91:../../devel/p5-Params-Validate
  +DEPENDS+= \ 
p5-Params-ValidationCompiler-[0-9]*:../../devel/p5-Params-ValidationCompiler
  +DEPENDS+= p5-Specio-[0-9]*:../../devel/p5-Specio
  +DEPENDS+= p5-namespace-autoclean-[0-9]*:../../devel/p5-namespace-autoclean
- for make test
  +BUILD_DEPENDS+= p5-Exception-Class-[0-9]*:../../devel/p5-Exception-Class