./time/p5-Time-Period, Perl5 module to deal with time periods

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.20nb8, Package name: p5-Time-Period-1.20nb8, Maintainer: pkgsrc-users

Period.pm is a Perl module to deal with time periods.


Required to run:
[lang/perl5]

Master sites: (Expand)

SHA1: 98d324e9858debfa918d60892600650230a86e87
RMD160: 4439c41e6f18498fd768f2bb0a44f75510284fa3
Filesize: 10.46 KB

Version history: (Expand)


CVS history: (Expand)


   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2012-10-08 15:04:32 by Aleksej Saushev | Files touched by this commit (146)
Log message:
Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.
   2012-10-03 23:59:10 by Thomas Klausner | Files touched by this commit (2798)
Log message:
Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.
   2011-08-14 17:28:49 by OBATA Akio | Files touched by this commit (61)
Log message:
Revision bump after updating perl5 to 5.14.1.
   2010-08-21 18:37:14 by Stoned Elipot | Files touched by this commit (1724) | Package updated
Log message:
Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!
   2008-10-19 21:19:25 by Havard Eidnes | Files touched by this commit (1179)
Log message:
Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=...").
   2008-06-12 04:14:58 by Joerg Sonnenberger | Files touched by this commit (1134)
Log message:
Add DESTDIR support.