./wip/p5-Unicode-CheckUTF8, Perl5 module to check if scalar is valid UTF-8

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.03, Package name: p5-Unicode-CheckUTF8-1.03, Maintainer: pkgsrc-users

This is an XS wrapper around some Unicode Consortium code to check if a string
is valid UTF-8, revised to conform to what expat/Mozilla think is valid UTF-8,
especially with regard to low-ASCII characters.

Note that this module has NOTHING to do with Perl's internal UTF8 flag on
scalars.

This module is for use when you're getting input from users and want to make
sure it's valid UTF-8 before continuing.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: aa50c4e0164f01328f5187ad26e5282382ce2148
RMD160: 10d75f78b06059dbb7e261385f81896e59923928
Filesize: 24.886 KB

Version history: (Expand)


CVS history: (Expand)


   2014-10-09 16:06:26 by Thomas Klausner | Files touched by this commit (97)
Log message:
Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.
   2012-10-04 21:11:57 by Aleksej Saushev | Files touched by this commit (56)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Mark packages that don't or might probably not have staged installation.
   2011-10-24 12:53:40 by Hiramatsu Yoshifumi | Files touched by this commit (2) | Package updated
Log message:
Update p5-Unicode-CheckUTF8 to 1.03.

Changes from previous:
1.03 (2010-12-20)
   - patch from Andrea Nall to use STRLEN in XS, preventing crash
     on 64-bit systems in some cases.  also const-ify stuff.

1.02 (unreleased)
   - more tests from other utf8 scripts I had around
   - test plans
   2008-08-27 21:50:48 by Cryo | Files touched by this commit (2)
Log message:
Removed PLIST, used the packing list in Makefile, and TODO is done.
Ready to be imported.
   2008-07-24 19:13:42 by Cryo | Files touched by this commit (3)
Log message:
Added TODO note. Fixed PLIST and made Makefile happy.
   2008-07-24 13:01:45 by Cryo | Files touched by this commit (1)
Log message:
pkglint lied... removed the turds that caused the errors.
   2008-07-24 12:47:25 by Cryo | Files touched by this commit (4) | Imported package
Log message:
Import p5-Unicode-CheckUTF8-1.01 as wip/p5-Unicode-CheckUTF8.

This is an XS wrapper around some Unicode Consortium code to check if a string
is valid UTF-8, revised to conform to what expat/Mozilla think is valid UTF-8,
especially with regard to low-ASCII characters.

Note that this module has NOTHING to do with Perl's internal UTF8 flag on
scalars.

This module is for use when you're getting input from users and want to make
sure it's valid UTF-8 before continuing.