./wip/py-llvmlite, Lightweight LLVM python binding for JIT compilers

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.14.0.dev, Package name: py27-llvmlite-0.14.0.dev, Maintainer: pkgsrc-users

A lightweight LLVM python binding for writing JIT compilers

The old llvmpy binding exposes a lot of LLVM APIs but the mapping of C++-style
memory management to Python is error prone. Numba and many JIT compilers do not
need a full LLVM API. Only the IR builder, optimizer, and JIT compiler APIs are
necessary.

llvmlite is a project originally tailored for Numba's needs, using the
following approach:
* A small C wrapper around the parts of the LLVM C++ API we need that are not
already exposed by the LLVM C API.
* A ctypes Python wrapper around the C API.
* A pure Python implementation of the subset of the LLVM IR builder that we
need for Numba.


Required to run:
[devel/py-setuptools] [lang/python27] [lang/llvm] [devel/py-enum]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 6a20e83932585c82c2c0fb507e3f500ad5497846
RMD160: 8e81a7b84cfd7b3a165b9c6ac648d4855a2e4933
Filesize: 135.859 KB

Version history: (Expand)