./www/ocsigen, Web programming framework for OCaml

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.9, Package name: ocsigen-2.9, Maintainer: jaapb

Ocsigen is a web programming framework for OCaml. It can be used as a web
server, serving static pages, but it is also possible to implement entire
web sites as OCaml modules.


Required to run:
[lang/ocaml] [net/ocamlnet] [security/ocaml-ssl] [devel/ocaml-findlib] [devel/pcre-ocaml] [archivers/ocaml-zip] [security/ocaml-cryptokit] [devel/ocaml-react] [textproc/ocaml-tyxml] [textproc/ocaml-text] [databases/ocaml-dbm] [net/ocaml-ipaddr] [devel/ocaml-lwt_ssl] [devel/ocaml-lwt_react] [devel/ocaml-lwt_log]

Required to build:
[pkgtools/cwrappers]

Package options: camlzip, gdbm

Master sites:

SHA1: 1b4d50c9b6fff3ab78c8aef3ebbde1f8ddcc594e
RMD160: f5114a7bda3327e279f57f40336a7c23e19b66ce
Filesize: 1235.522 KB

Version history: (Expand)


CVS history: (Expand)


   2018-04-13 15:15:01 by Jaap Boender | Files touched by this commit (21) | Package updated
Log message:
Updated www/ocsigen to version 2.9.

This release adds support for OCaml 4.06 and Lwt 3 (and 4), removes
support for Camlp4 and includes various other small improvements and
bugfixes.
   2018-01-28 21:11:10 by Thomas Klausner | Files touched by this commit (462) | Package updated
Log message:
Bump PKGREVISION for gdbm shlib major bump
   2018-01-10 17:53:15 by Jaap Boender | Files touched by this commit (107) | Package updated
Log message:
Recursive revbump associated with the update to OCaml 4.06.
   2017-09-08 19:10:46 by Jaap Boender | Files touched by this commit (12)
Log message:
No substantive changes, but a lot of patches to make Ocsigen work with
ocaml-lwt 3. Most of these are already in the upstream github, so should
be removed at the next release.
   2017-07-11 16:19:47 by Jaap Boender | Files touched by this commit (1)
Log message:
Revbump associated with ocaml-4.04.2
   2017-01-04 14:06:18 by Jaap Boender | Files touched by this commit (3)
Log message:
PostgreSQL support is now optional. No upstream changes.
   2016-12-30 12:55:53 by Jaap Boender | Files touched by this commit (7) | Package updated
Log message:
Updated package to latest version, 2.8. Changes include:
* PostgreSQL Ocsipersist backend
* Compatibility with TyXML 4.0.x
* Export OpenSSL options through configuration file
* Various small fixes and improvements
   2016-06-25 16:33:41 by Jaap Boender | Files touched by this commit (2) | Package updated
Log message:
Updated package to use ocaml.mk framework. No upstream changes.