./www/p5-Catalyst-Plugin-Session, Generic Catalyst Session plugin

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.40nb1, Package name: p5-Catalyst-Plugin-Session-0.40nb1, Maintainer: pkgsrc-users

The Session plugin is the base of two related parts of functionality
required for session management in web applications.

The first part, the State, is getting the browser to repeat back a
session key, so that the web application can identify the client and
logically string several requests together into a session.

The second part, the Store, deals with the actual storage of information
about the client. This data is stored so that the it may be revived for
every request made by the same client.

This plugin links the two pieces together.


Required to run:
[lang/perl5] [devel/p5-MRO-Compat] [devel/p5-Object-Signature] [www/p5-Catalyst-Runtime] [devel/p5-namespace-clean] [devel/p5-Moose] [devel/p5-MooseX-Emulate-Class-Accessor-Fast]

Required to build:
[devel/p5-Test-Exception] [devel/p5-Test-Deep]

Master sites: (Expand)

SHA1: 33ca527664e3b68d993bed564c7348ae79a7d4a2
RMD160: 084091662ce3a3238b1f2a91845e29578d76c028
Filesize: 48.636 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-01-17 00:34:29 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update to 0.40
--------------
0.40 2015-01-26
  - Add a flag so that a storage can finalize during finalize_header rather
    than finalize_body.  This is to enable storages that need to write to the
    HTTP header (such as the cookie based store).
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2014-02-06 11:42:40 by David Brownlee | Files touched by this commit (2) | Package updated
Log message:
Updated www/p5-Catalyst-Plugin-Session to 0.39

Revision history for Perl extension Catalyst::Plugin::Session

0.39 2013-10-16
      - Fixed a bug when "expiry_threshold" is non-zero, where changes \ 
to the
      session were not saved.

0.38 2013-09-18
      - New feature: "expiry_threshold" which allows you more control \ 
over when
      this plugin checks and updates the expiration date for the session.
      This is useful when you have high traffic and need to reduce the number
      of session expiration hits (like if you are using a database for sessions
      and your db is getting pounded).
   2013-12-09 15:17:56 by OBATA Akio | Files touched by this commit (238) | Package updated
Log message:
Fix/Update DEPENDS paterns for perl CORE modules, with some trivial fixes.

Bump PKGREVISION for runtime dependency pattern changed packages.