./www/p5-HTTP-Entity-Parser, PSGI compliant HTTP Entity Parser

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.21nb1, Package name: p5-HTTP-Entity-Parser-0.21nb1, Maintainer: pkgsrc-users

HTTP::Entity::Parser is PSGI compliant HTTP Entity parser. This module
also has compatibility with HTTP::Body. Unlike HTTP::Body, HTTP::Entity::Parser
reads HTTP entity from PSGI's env $env->{'psgi.input'} and parse it.
This module support application/x-www-form-urlencoded, multipart/form-data
and application/json.


Required to run:
[lang/perl5] [devel/p5-Hash-MultiValue] [devel/p5-Stream-Buffered] [converters/p5-JSON-MaybeXS] [www/p5-WWW-Form-UrlEncoded] [www/p5-HTTP-MultiPartParser]

Required to build:
[converters/p5-JSON] [www/p5-HTTP-Message] [devel/p5-Module-Build-Tiny] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 57285459d61cf7d34f02d3bbafee5fe70a330258
RMD160: c6f3cd85effa6137eb3041aa4b0f3be6f23a310d
Filesize: 23.177 KB

Version history: (Expand)


CVS history: (Expand)


   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-03-04 17:10:04 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-HTTP-Entity-Parser: update to 0.21.

0.21 2018-03-03T04:51:32Z

   - Relax minimum perl version to 5.8.1
   2017-09-27 18:26:16 by Thomas Klausner | Files touched by this commit (1)
Log message:
p5-HTTP-Entity-Parser: fix some dependencies

They are needed at run-time, not only for tests.
   2017-09-27 17:18:27 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-HTTP-Entity-Parser: update to 0.20.

0.20 2017-07-18T03:54:04Z

   - [fixed] Throws exception when psgi.input is undef #6
   - [fixed] dechunk loop can stuck on empty chunked post #7

0.19 2017-02-07T08:19:45Z

   - Adjust tests for module load from a relative path when . is not in @INC \ 
(Thank you toddr)
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-02-02 13:39:46 by Makoto Fujiwara | Files touched by this commit (1)
Log message:
 -- Add one more package with BUILD_DEPENDS for make test.
   2017-02-02 13:01:48 by Makoto Fujiwara | Files touched by this commit (1)
Log message:
 -- Add 4 packages with BUILD_DEPENDS for make test
   2016-12-11 08:29:12 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.18

Upstream changes:
0.18 2016-10-03T04:36:04Z

   - Use a better tempdir, fix some documentation, and make json test more \ 
readable #4 (Thank you karenetheridge)