./www/p5-LWPx-ParanoidAgent, Subclass of module LWP::UserAgent that protects you from harm

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.12, Package name: p5-LWPx-ParanoidAgent-1.12, Maintainer: pkgsrc-users

The Perl module LWPx::ParanoidAgent is a subclass of LWP::UserAgent,
but paranoid against attackers. It's to be used when you're fetching a
remote resource on behalf of a possibly malicious user.

This class can do whatever LWP::UserAgent can (callbacks, uploads from
files, etc), except proxy support is explicitly removed, because in that
case you should do your paranoia at your proxy. Only "http:" and "https:"
URL schemes are supported.


Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: dc22bef4cb0b92a9e0f5026aa5adc6a5b6064b33
RMD160: 61dc1e5f81c1b79cedae8e67167d467cbb853389
Filesize: 56.08 KB

Version history: (Expand)


CVS history: (Expand)


   2017-09-27 17:59:47 by Thomas Klausner | Files touched by this commit (5) | Package removed
Log message:
p5-LWPx-ParanoidAgent: update to 1.12.

1.12    2016-09-29
	- Fix to work with Net::DNS 1.03 (RT#108745)
	  Net::DNS::bgsend()/bgread() API changed in a backward-incompatible
	  way in 1.03. Deal with either a IO::Select object or a socket, as it
	  was before.  (Cosimo Streppone <cosimo@cpan.org>)
    - fixed: https://github.com/csirtgadgets/LWPx-Pa … /issues/18
    - fixed: https://github.com/csirtgadgets/LWPx-Pa … /issues/14

1.11	2014-
	- fixed read-timeout issue: \ 
https://github.com/csirtgadgets/LWPx-Pa … t/issues/7
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-09-18 00:46:17 by Amitai Schlair | Files touched by this commit (5) | Package updated
Log message:
Apply patches from upstream git and Debian to fix reading long
documents over IO::Socket::SSL, then stop forcing Net::SSL (which
doesn't verify hostnames) even when the admin requested IO::Socket::SSL,
and then pass the server name through so SNI can work. Bump PKGREVISION.

Updating during the freeze for the security improvements.
   2014-06-09 22:08:15 by Amitai Schlair | Files touched by this commit (2) | Package updated
Log message:
Update to 1.10. From the changelog:

- fixed: IO::Socket::SSL related warning (GitHub issue #3)
- fixed: "500 Can't read entity body" with IO::Socket:SSL (GitHub issue #4)
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.