./www/py-selenium, Python bindings for Selenium

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.8.1, Package name: py27-selenium-3.8.1, Maintainer: pkgsrc-users

Python language bindings for Selenium WebDriver.
The selenium package is used to automate web browser interaction from Python.


Required to run:
[devel/py-setuptools] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: dfadc2d28e5a0feb2600050deed134605477f7fa
RMD160: b1a99aa68e14e267d521a42c91c6c53898dcbf92
Filesize: 829.499 KB

Version history: (Expand)


CVS history: (Expand)


   2018-01-04 21:46:21 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-selenium: updated to 3.8.1

Selenium 3.8.1
* Fix bug when creating an Opera driver
* Stop sending sessionId in w3c payload.
* Fix issue with w3c actions releasing on element
* A more descriptive log message is displayed if the port cannot be connected
* Initialize Alert object by calling alert.text
* PhantomJS is now deprecated, please use either Chrome or Firefox in headless mode
* Legacy Firefox driver: ensuring copy of profile dir, its 'extensions' subdir \ 
and 'user.js' file are writable.
   2017-12-01 11:02:29 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-selenium: updated to 3.8.0

Selenium 3.8.0
* Firefox options can now be imported from selenium.webdriver as FirefoxOptions
* Headless mode can now be set in Chrome Options using `set_headless`
* Headless mode can now be set in Firefox Options using `set_headless`
* Add the WebKitGTK WebDriver and options class
* Browser options can now be passed to remote WebDriver via the `options` parameter
* Browser option parameters are now standardized across drivers as `options`. \ 
`firefox_options`,
  `chrome_options`, and `ie_options` are now deprecated
* Added missing W3C Error Codes
* Support has been removed for Python versions 2.6 and 3.3
   2017-11-17 09:15:43 by Adam Ciarcinski | Files touched by this commit (18) | Package removed
Log message:
py-selenium: downgraded to 3.7.0

The package was actually 3.7.0, but marked as 3.7.1.
Now, it does not depend on Java, and pulls the (pre-built) distfile from PyPI.
   2017-11-11 22:30:21 by Tobias Nygren | Files touched by this commit (18)
Log message:
www/py-selenium: import py27-selenium-3.7.1

Python language bindings for Selenium WebDriver.
The Selenium package is used to automate web browser interaction from Python.