NOTICE: This package has been removed from pkgsrc

./www/ruby-rack12, Ruby webserver interface

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ]


Branch: CURRENT, Version: 1.2.8, Package name: ruby193-rack-1.2.8, Maintainer: pkgsrc-users

Rack provides a minimal, modular and adaptable interface for developing
web applications in Ruby. By wrapping HTTP requests and responses in
the simplest way possible, it unifies and distills the API for web
servers, web frameworks, and software in between (the so-called
middleware) into a single method call.


Required to run:
[lang/ruby193-base]

Master sites:

SHA1: dd19c41600f49709c3540028efbdb9fb9d0888b6
RMD160: 9d92345e8b027368b80e3e3f85f540d8dafa15b2
Filesize: 141 KB

Version history: (Expand)


CVS history: (Expand)


   2013-02-17 10:05:46 by Takahiro Kambe | Files touched by this commit (4) | Package removed
Log message:
Remove ruby-rack12 which was required by www/ruby-actionpack3.
   2013-02-08 14:19:13 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rack12 to 1.2.8.

* February 7th, Thirty fifth public release 1.1.6, 1.2.8, 1.3.10
  * Fix CVE-2013-0263, timing attack against Rack::Session::Cookie
   2013-01-31 17:03:34 by Takahiro Kambe | Files touched by this commit (4) | Package updated
Log message:
Update HOMEPAGE to github's one.
   2013-01-14 05:34:27 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rack12 to 1.2.7.

* January 6th, 2013: Twenty seventh public release 1.2.6
  * Add warnings when users do not provide a session secret
  * Fix parsing performance for unquoted filenames

* January 13th, 2013: Thirty second public release 1.4.4, 1.3.9, 1.2.7, 1.1.5
  * [SEC] Rack::Auth::AbstractRequest no longer symbolizes arbitrary strings
  * Fixed erroneous test case in the 1.3.x series
   2012-01-08 12:04:54 by OBATA Akio | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rack12 to 1.2.5.

* December 28th, 2011: Twenty second public release: 1.2.5
  * Security fix. http://www.ocert.org/advisories/ocert-2011-003.html
    Further information here: http://jruby.org/2011/12/27/jruby-1-6-5-1
   2011-12-15 15:22:21 by Takahiro Kambe | Files touched by this commit (4) | Imported package
Log message:
Importing ruby-rack version 1.2.4 as www/ruby-rack12.