./x11/gtkmm, C++ interface to Gtk+ v2

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.24.5nb4, Package name: gtkmm-2.24.5nb4, Maintainer: adam

gtkmm (previously known as Gtk--) is the official C++ interface for the
popular GUI library GTK+. Highlights include typesafe callbacks, widgets
extensible via inheritance and a comprehensive set of widget classes that
can be freely combined to quickly create complex user interfaces. Here's
an overview, with documentation and status. gtkmm is free software
distributed under the GNU Library General Public License (LGPL).

Aside from the C++ interface to Gtk 2.x, this package also provides
bindings for glib, atk and pango (all of them related with the toolkit).


Required to run:
[lang/perl5] [devel/glibmm] [x11/gtk2] [devel/pangomm] [devel/atkmm]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites: (Expand)

SHA1: dcb41b487577594a5ecf0dee3c4993ff9a2ade26
RMD160: dc7d0701d6e7906a80b500e6a42e04e07620cd63
Filesize: 11740.258 KB

Version history: (Expand)


CVS history: (Expand)


   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2017-08-01 16:59:08 by Thomas Klausner | Files touched by this commit (211)
Log message:
Follow some http -> https redirects.
   2017-05-03 10:38:46 by Jonathan Perkin | Files touched by this commit (95)
Log message:
Convert CXXFLAGS setting C++ standard to USE_LANGUAGES.
   2017-02-12 07:26:18 by Ryo ONODERA | Files touched by this commit (1451)
Log message:
Recursive revbump from fonts/harfbuzz
   2017-02-06 14:56:14 by Thomas Klausner | Files touched by this commit (1452)
Log message:
Recursive bump for harfbuzz's new graphite2 dependency.
   2016-09-16 23:47:48 by Patrick Welche | Files touched by this commit (4) | Package updated
Log message:
Update gtkmm to 2.24.5

2.24.5 (stable)

This release can be used together with glibmm up to at least 2.49.5.
It's recommended that you use gtkmm3 instead of gtkmm2. The support for
gtkmm2 is minimal, and diminishing.

Build:
* Update the MSVC projects (Chun-wei Fan)
* Use C++11 if the compiler supports it (Murray Cumming)
* Update to be compatible with new versions of glibmm
  (Kjell Ahlstedt, Murray Cumming)

Documentation:
* Improve the documentation of Gtk::ComboBoxText
  (Kjell Ahlstedt) Bug #766039 (Omega Phil)
   2016-08-03 12:23:40 by Adam Ciarcinski | Files touched by this commit (1248) | Package updated
Log message:
Revbump after graphics/gd update