./x11/libXinerama, X PanoramiX extension library

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.1.3, Package name: libXinerama-1.1.3, Maintainer: joerg

libXinerama provides X PanoramiX extension library.


Required to build:
[pkgtools/x11-links] [x11/xineramaproto] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 6a3956d73f7457ef0b4db12806d99c6918e328e3
RMD160: cb33f9ed40d138411ad31377619bee9a3686fdea
Filesize: 271.51 KB

Version history: (Expand)


CVS history: (Expand)


   2016-02-26 12:27:22 by Jonathan Perkin | Files touched by this commit (98)
Log message:
Use OPSYSVARS.
   2015-11-04 04:29:14 by Alistair G. Crooks | Files touched by this commit (670)
Log message:
Add SHA512 digests for distfiles for x11 category

Problems found locating distfiles:
        Package modular-xorg-server: missing distfile xorg-server-1.17.4.tar.bz2
        Package py-qt4: missing distfile PyQt-mac-gpl-4.11.1.tar.gz
        Package xservers: missing distfile xservers-3.3.6.5.tar.bz2
        Package xview-clients: missing distfile xview3.2p1-X11R6.tar.gz
        Package xview-lib: missing distfile xview3.2p1-X11R6.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2014-10-09 16:07:17 by Thomas Klausner | Files touched by this commit (1163)
Log message:
Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.
   2014-04-22 13:27:35 by OBATA Akio | Files touched by this commit (1)
Log message:
set required xineramaproto version, per configure request.
   2014-03-10 12:05:54 by Jonathan Perkin | Files touched by this commit (57)
Log message:
Search for pkgconfig files in lib${LIBABISUFFIX} and share directories
as appropriate.  This is required for X11_TYPE=native on Red Hat Linux.
   2013-05-31 10:24:06 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 1.1.3:

This bug fix release primarily provides the fix for the recently announced
security vulnerability CVE-2013-1985.

Adam Jackson (1):
      configure: Remove AM_MAINTAINER_MODE

Alan Coopersmith (3):
      Use _XEatDataWords to avoid overflow of _XEatData calculations
      integer overflow in XineramaQueryScreens() [CVE-2013-1985]
      libXinerama 1.1.3

Colin Walters (1):
      autogen.sh: Implement GNOME Build API
   2012-10-29 06:07:25 by Aleksej Saushev | Files touched by this commit (563)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2012-10-23 12:24:24 by Thomas Klausner | Files touched by this commit (215)
Log message:
Remove xextproto/buildlink3.mk in most cases where it occurs with
libXext/buildlink3.mk, now that it is included there.
Leave the places where its API version is set or variables from it
are used directly (about 3 packages).