./x11/ocaml-lablgtk, GTK+ 2.x bindings for Objective Caml

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.18.6nb4, Package name: ocaml-lablgtk-2.18.6nb4, Maintainer: jaapb

LablGTK is an Objective Caml interface to GTK+. This version
supports GTK+ from 2.0 to 2.10.

It uses the rich type system of Objective Caml 3 to provide a
strongly typed, yet very comfortable, object-oriented interface to
GTK+. This is not that easy if you know the dynamic typing approach
taken by GTK+.


Required to run:
[textproc/libxml2] [textproc/gtkspell] [graphics/cairo] [graphics/libgnomecanvas] [graphics/librsvg] [lang/ocaml] [devel/atk] [devel/glib2] [devel/libglade] [devel/ocaml-findlib] [devel/libgnomeui] [devel/pango] [x11/gtk2] [x11/gtksourceview] [x11/gnome-panel] [graphics/libart] [x11/gtksourceview2] [graphics/gdk-pixbuf2]

Required to build:
[pkgtools/x11-links] [x11/compositeproto] [x11/glproto] [x11/renderproto] [x11/xproto] [x11/xf86vidmodeproto] [x11/recordproto] [x11/xf86driproto] [x11/damageproto] [x11/inputproto] [x11/xextproto] [x11/randrproto] [x11/dri2proto] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers]

Package options: glade, gnome, gnomecanvas, gtksourceview, gtksourceview2, gtkspell, svg

Master sites:

SHA1: 2dd099ecca246274df8f6f363c8d418ff3a67568
RMD160: 6fef28c6ec2757da3e0773d33c77c13abaf61895
Filesize: 785.974 KB

Version history: (Expand)


CVS history: (Expand)


   2018-01-10 17:53:15 by Jaap Boender | Files touched by this commit (107) | Package updated
Log message:
Recursive revbump associated with the update to OCaml 4.06.
   2017-11-30 17:45:43 by Adam Ciarcinski | Files touched by this commit (654) | Package updated
Log message:
Revbump after textproc/icu update
   2017-11-23 18:20:22 by Thomas Klausner | Files touched by this commit (556)
Log message:
recursive bump for libxkbcommon removal from at-spi2-core
   2017-11-09 11:57:57 by Jaap Boender | Files touched by this commit (3)
Log message:
Added patch to x11/ocaml-lablgtk for compilation with ocaml 4.05
   2017-11-01 10:25:36 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated package x11/ocaml-lablgtk to version 2.18.6.

This release adds support for OCaml 4.06.
   2017-09-18 11:53:40 by Maya Rashish | Files touched by this commit (676)
Log message:
revbump for requiring ICU 59.x
   2017-09-08 11:51:27 by Jaap Boender | Files touched by this commit (113) | Package updated
Log message:
Recursive revbump associated with update of ocaml to 4.05
   2017-09-05 07:01:37 by David A. Holland | Files touched by this commit (1)
Log message:
Turns out this also needs to export libgnomecanvas if built with
libgnomecanvas. Found while building ocamlgraph with ocaml-lablgtk
support (which is required by pending new frama-c)...