./x11/py-Tk, Tkinter -- Python interface to Tcl/Tk

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.7.14nb5, Package name: py27-Tk-2.7.14nb5, Maintainer: pkgsrc-users

This package provides C binding to libtk and libtcl, necessary for
Tkinter to work. All other needed files (Tkinter.py and friends)
are part of standard Python installation.


Required to run:
[lang/tcl] [x11/tk] [lang/python27]

Required to build:
[pkgtools/x11-links] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: cf146474fc988b4b6b53fdd81b71c2815873b469
RMD160: 816553f988c661cfe31b6e89a513fdfbf87963d5
Filesize: 12281.359 KB

Version history: (Expand)


CVS history: (Expand)


   2018-04-03 20:22:47 by Adam Ciarcinski | Files touched by this commit (1)
Log message:
py-Tk: Darwin does not need libX11
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2018-02-05 12:36:39 by Jonathan Perkin | Files touched by this commit (1)
Log message:
py-Tk: Spell buildlink3 correctly.
   2017-09-04 20:08:31 by Thomas Klausner | Files touched by this commit (163)
Log message:
Follow some redirects.
   2016-02-02 08:38:29 by Darrin B. Jewell | Files touched by this commit (1)
Log message:
add explicit dependency on libX11
fixes build on Darwin
   2015-07-04 18:18:44 by Joerg Sonnenberger | Files touched by this commit (222)
Log message:
Remove USE_X11BASE and X11PREFIX.
   2015-05-27 22:46:34 by Thomas Klausner | Files touched by this commit (1)
Log message:
Fix build on NetBSD. From adam@
   2014-03-13 12:08:54 by Jonathan Perkin | Files touched by this commit (67)
Log message:
Set USE_GCC_RUNTIME=yes for packages which build shared libraries but do
not use libtool to do so.  This is required to correctly depend upon a
gcc runtime package (e.g. gcc47-libs) when using USE_PKGSRC_GCC_RUNTIME.