./x11/xf86-video-mach64, Modular Xorg ATI Mach64 video driver

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 6.9.5nb1, Package name: xf86-video-mach64-6.9.5nb1, Maintainer: joerg

This is the video driver for ATI Mach64 cards for the modular Xorg server.


Required to run:
[x11/libdrm] [x11/modular-xorg-server]

Required to build:
[pkgtools/x11-links] [x11/compositeproto] [x11/scrnsaverproto] [x11/glproto] [x11/renderproto] [x11/xproto] [x11/xf86vidmodeproto] [x11/fontsproto] [x11/xf86driproto] [x11/damageproto] [x11/inputproto] [x11/resourceproto] [x11/videoproto] [x11/xextproto] [x11/xf86miscproto] [x11/xineramaproto] [x11/randrproto] [x11/dri2proto] [x11/fixesproto4] [x11/presentproto] [x11/dri3proto]

Master sites: (Expand)

SHA1: 0ba2d51752a62808286937cf3c6a95794fa5cb29
RMD160: da9f300ccd028850505b7a474fdecbaf09ea50b2
Filesize: 508.675 KB

Version history: (Expand)


CVS history: (Expand)


   2016-02-26 12:27:22 by Jonathan Perkin | Files touched by this commit (98)
Log message:
Use OPSYSVARS.
   2016-01-05 14:11:46 by Tobias Nygren | Files touched by this commit (53)
Log message:
Bump revision for xorg-server-1.18 driver ABI bump
   2015-11-04 04:29:14 by Alistair G. Crooks | Files touched by this commit (670)
Log message:
Add SHA512 digests for distfiles for x11 category

Problems found locating distfiles:
        Package modular-xorg-server: missing distfile xorg-server-1.17.4.tar.bz2
        Package py-qt4: missing distfile PyQt-mac-gpl-4.11.1.tar.gz
        Package xservers: missing distfile xservers-3.3.6.5.tar.bz2
        Package xview-clients: missing distfile xview3.2p1-X11R6.tar.gz
        Package xview-lib: missing distfile xview3.2p1-X11R6.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-25 02:44:45 by Tobias Nygren | Files touched by this commit (12)
Log message:
don't include Mesa's bl3 directly. It needs to come in via xorg-server's
bl3 since that decides which mesa version to use.
   2015-05-06 00:21:19 by Thomas Klausner | Files touched by this commit (2)
Log message:
Remove obsolete patches.
   2015-05-04 22:30:01 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 6.9.5:

Adam Jackson (3):
      preinit: Don't bother explicitly loading int10, vbe will do it for us
      Bump minimum xserver to 1.4
      mach64 6.9.5

Alan Coopersmith (2):
      Remove unused atidecoder.c & atidecoder.h
      Remove unused atiaudio.c & ATIAudioNames declaration

Connor Behan (1):
      Drop dependence on xf86PciInfo.h

Dave Airlie (1):
      mach64: fix build probably not required with pci access anyways

Matthieu Herrb (1):
      Deal with pPict->pDrawable == NULL for source-only pictures.
   2015-04-25 16:25:26 by Tobias Nygren | Files touched by this commit (687) | Package updated
Log message:
Recursive revbump following MesaLib update, categories p through x.
   2015-04-03 11:59:59 by Tobias Nygren | Files touched by this commit (43)
Log message:
Revbump all the xf86-* driver packages so current binary packages get the
modular-xorg-server<1.17 dependency expressed.