Next | Query returned 7 messages, browsing 1 to 10 | previous

History of commit frequency

CVS Commit History:


   2021-02-03 15:27:36 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.4.9

3.4.9 (2021-01-27)

* Powershell process keep running with local train transport. #660
  (Vasu1105)

3.4.8 (2021-01-26)

* su - USER command execution support & change transport_options to
  attr_accessor #636 (vsingh-msys)
   2021-01-13 15:45:10 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.4.7

3.4.7 (2021-01-11)

Merged Pull Requests

* Update chefstyle requirement from 1.5.7 to 1.5.9 #654
  (dependabot-preview[bot])
* Update google API upper constraints to allow Ruby 3 #656 (clintoncwolfe)
* Test on ruby 3.0, drop testing on ruby 2.4 #657 (clintoncwolfe)

3.4.4 (2020-12-14)

Merged Pull Requests

* Update parallel requirement from < 1.20.0 to < 1.21.0 #651
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.5.0 to 1.5.7 #652
  (dependabot-preview[bot])
* Use IdentitiesOnly only when keys are present #650 (drbrain)

3.4.1 (2020-12-07)

Merged Pull Requests

* Change timeout log entry to debug #643 (james-stocks)
* Update chefstyle requirement from 1.4.5 to 1.5.0 and pin parallel for
  ruby 2.4 #648 (dependabot-preview[bot])
* Support unpacking train options from URI query values #642 (lamont-granquist)
* Make :forward_agent a valid SSH option #649 (drbrain)

3.3.27 (2020-10-19)

Merged Pull Requests

* Check stdout even when exit_status is 0, and handle JSON.parse exception
  #601 (CodesWhisperer)
* Update chefstyle requirement from 1.3.2 to 1.4.5 #646
  (dependabot-preview[bot])
* Use the build in Expeditor gem caching #647 (tas50)

v3.3.24 (2020-09-30)

Merged Pull Requests

* Further optimize requires for external libraries #639 (tas50)
* Update chefstyle requirement from 1.2.1 to 1.3.2 #634
  (dependabot-preview[bot])
* Allow timeout option per ssh command #625 (james-stocks)
   2020-09-14 16:17:11 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.3.21

Update ruby-train-core package to 3.3.21.

3.3.21 (2020-09-14)

Merged Pull Requests

* Resolve test failures on Ruby 2.4 #632 (tas50)
* Update chefstyle requirement from 1.2.0 to 1.2.1 #631
  (dependabot-preview[bot])
* Update Google gem versions for train #635 (lhasadreams)
* Switch from FILE to dir where we can #638 (tas50)
* Allow for docker-api 2.x #637 (tas50)

3.3.16 (2020-08-17)

Merged Pull Requests

* Fix spelling mistakes including misidentification of XenServer #628
  (tas50)
* Remove 1.x branch config from Expeditor #622 (tas50)
* Speed up requires in non-omnibus Ruby installs #630 (tas50)

3.3.13 (2020-08-05)

Merged Pull Requests

* Update chefstyle requirement from 1.1.1 to 1.1.2 #619
  (dependabot-preview[bot])
* Get the old integration tests closer to running #620 (tas50)
* Run Chefstyle on the oldest ruby we support #621 (tas50)
* Remove the redundant encoding comments #623 (tas50)
* Update chefstyle requirement from 1.1.2 to 1.1.3 #624
  (dependabot-preview[bot])
* Avoid minor rubocop warning #626 (tas50)
* Update chefstyle requirement from 1.1.3 to 1.2.0 #627
  (dependabot-preview[bot])

3.3.6 (2020-07-02)

Merged Pull Requests

* Fix incorrect error message when password is expired #616 (vsingh-msys)
* Properly detect macOS Big Sur as being platform mac_os_x #618 (tas50)

3.3.4 (2020-06-25)

Merged Pull Requests

* Add DragonflyBSD detection #614 (tecracer-theinen)
* Update chefstyle requirement from 1.1.0 to 1.1.1 #611
  (dependabot-preview[bot])
* Fix SSH Connection reuse #613 (tecracer-theinen)
   2020-06-13 17:42:43 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.3.1

Update ruby-train-core to 3.3.1.

3.3.1 (2020-06-10)

* Update chefstyle requirement from 1.0.5 to 1.1.0 #608
  (dependabot-preview[bot])
* Update to net-ssh 6 and allow older algorithms #603 (james-stocks)
* Update ffi dependency #610 (james-stocks)
   2020-04-30 17:59:11 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.2.28

Update ruby-train-core to 3.2.28.

v3.2.28 (2020-04-13)

Merged Pull Requests

* [chef#9635] Add reason for sudo root password #583 (vsingh-msys)

v3.2.27 (2020-04-08)

Merged Pull Requests

* Silence deprecation warning under ruby 2.7 #582 (clintoncwolfe)
   2020-03-24 16:33:06 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
net/ruby-train-core: update to 3.2.26

Update ruby-train-core to 3.2.26.

3.2.26 (2020-03-20)

Merged Pull Requests

* Update rake dep for security issue #577 (clintoncwolfe)
* Move dependency on inifile from train-core to train #579 (terceiro)
* Avoid explicit /tmp in favor of $TMPDIR #578 (majioa)
   2020-01-19 16:08:59 by Takahiro Kambe | Files touched by this commit (4)
Log message:
net/ruby-train-core: add version 3.2.5 package

Add ruby-train-core version 3.2.5 package.

train-core

A minimal Train with a backends for ssh and winrm.

Next | Query returned 7 messages, browsing 1 to 10 | previous