Subject: CVS commit: pkgsrc
From: Leonardo Taccari
Date: 2018-06-03 09:49:27
Message id: 20180603074927.8B3A0FBEC@cvs.NetBSD.org

Log Message:
python27: Remove patches/patch-ah (no longer needed)

Since Python 2.7.15 patches/patch-ah is no longer needed and badly interfere
(e.g. with it `curses.KEY_*' are no longer exposed):

 - Prototypes of NetBSD curses(3) are as described, no need to patch them
 - Avoid {lines,columns} -> {nlines,columns} rename, they are properly
   undef-ed due HAVE_TERM_H.
 - Use keyname() (it should be present since NetBSD 2.0)

Bump PKGREVISION for devel/py-curses so it will be properly rebuild.

Fixes PR pkg/53330 reported by <oster>.

Files:
RevisionActionfile
1.9removepkgsrc/lang/python27/patches/patch-ah
1.69modifypkgsrc/lang/python27/distinfo
1.47modifypkgsrc/devel/py-curses/Makefile