Subject: CVS commit: pkgsrc/cross/cc65
From: Nia Alarie
Date: 2020-12-08 12:32:01
Message id:

Log Message:
cc65: Update to 2.19

Björn Esser (5):
      Replace GIT_SHA with a more versatile BUILD_ID definition.
      test/ref/otccex: Fix ramdomly occurring segfault.
      util/zlib/deflater: Fix several compiler warnings.
      zlib: Use correct (un)signedness of char in prototypes and functions.
      src/Makefile: Simplify BUILD_ID logic.

Chris Cacciatore (2):
      Added support for --large-alignment in ld65.
      Removed invalid link to ca65 document.

Curt J. Sampson (2):
      libsrc/*/kplot.s: Use symbols, not hardcoded addrs
      vic20/cputc: Fix incorrect CRAM_PTR at startup when using conio

Daniel Serpell (1):
      Fixes Atari OS devhdl_t, init field needs an JMP byte.

Dirk Jagdmann (2):
      fix whitespace
      fix the clean: target to remove any disk images.

Fabrizio Caruso (23):
      Fix Gamate RVS
      Hello world example for the Supervision
      Move screen init into crt0.s
      Improve init code readability
      Improve helloworld example for Supervision
      Add supervisionhello in samples/Makefile
      Use decimal for lcd size initialization
      Improve comments
      Init is no longer in crt0.s
      Fix char 35 38 42 47 52
      Fix 4
      M N fixed
      Fix left arrow (char 77=13+64)
      Fix 127 (second left arrow)
      small m and n fixed
      Tentative solution for cgetc in Lynx
      Remove useless tax
      remove bra
      Second tentative fix
      kbhit checks KBEDG and getc resets KBEDG

Greg King (38):
      Made the ld65 configure file's segment offset attribute accept zero as a value.
      Changed empty parameter lists into (void) lists on functions with asm() \ 
      Allowed old-style (K and R) function declarations to be fastcall.
      Added a charmap header that converts no character encodings.
      Added a .ORG keyword to ca65 structs/unions.
      Created a target and a library for the Commander X16 prototype computer.
      Updated the cx16 start-up to the emulator's release 32.
      Put the C64 code into cx16/_scrsize.s.
      Fixed a typo in the cx16 document.
      Added character codes to change between the two CBM fonts.
      Fixed cgetc().
      Made the "none" CPU allow all address sizes.
      Added new program descriptions to the list.
      Fixed problems with the Atari Lynx's TGI driver.
      Fixed error handling for missing names in ld65 configure files.
      Added the GIF switch to the X16 emulator's control port.
      Added VERA peek() and poke() to the cx16 library.
      Made assert() send SIGABRT when an assertion fails.
      Changed a "See also" link in the abort() and assert() \ 
descriptions from raise() to signal().
      Updated cx16 to match the Commander X16 ROMs and emulator, release 34.
      Added a standard mouse driver to the cx16 library.
      Added <cx16.h> to the function reference document.
      Changed sim65's internal error codes from 9-bit values to 7-bit values.
      Added the missing BANK_RAM array to the Commander X16's header.
      Updated the cx16 library to the Commander X16 Kernal's prerelease 35.
      Made the program-chaining exec() handle the X16 emulator's file-system.
      Added real-time clock functions to the cx16 library.
      Fixed the target guards around the usage messages.
      Made ca65 give error messages when it sees duplicate .define commands.
      Updated the cx16 library to the ROM's prerelease 36.
      Made cc65 detect a possibly missing argument at the end of a function \ 
argument list.
      Fixed a typo in commit 2e5fbe89cd3f67b06b292936dfdf4fdb104b7112.
      Fixed an error message printer.
      Added missing <tag> and <itemize> Linuxdoc tags to some \ 
ctype.h function descriptions.
      Updated the cx16 library to the Commander X16's ROM prerelease 37.
      Fixed some typos in the "large alignment" support.
      Added a JOY_FIRE() macro to the Atmos and Telestrat C headers.
      Put the Telestrat static drivers names together.

IrgendwerA8 (3):
      ctype size optimization
      Changes resulting from code review.
      Changes resulting from 2nd code review

Jeff Tranter (1):
      New OSI input routine based on disassembly of ROM code.

Jeremy Chadwick (3):
      doc: clarify need for .IMPORT on some special symbols
      Grammatical modifications
      Use the word 'macros' universally (not macroes)

Jeremy Rand (1):
      Update get_ostype.s

      Significantly faster rand() implementation
      Update comments in rand.s
      [cx16] Update ROM banks to new mapping

Lauri Kasanen (3):
      cc65: Add support for binary literals
      binlit: Add a few random leading zeros
      Document binary literals

Oliver Schmidt (15):
      Reduced shadow for h2 to improve readability.
      Minor URL update.
      Use MACHID to check for realtime clock.
      Expanded Sim65 zero page.
      Minor cleanup.
      Normalized Atari naming.
      Made use of 65C02 opcode (thx to polluks).
      Adjusted comments due to recent change.
      Matched comment to the one in the C header file.
      Some style adjustments.
      Adjusted tolower() and toupper() to
      Fixed tolower() and toupper() to save high byte.
      Shortened names and adjusted style.
      Disable potentially enabled double-width graphics.
      Removed --lib option from cl65.

Piotr Fusik (4):
      Optimize a negation in signed division.
      Don't set carry when already set.
      Swap the positive/negative paths to save a branch.
      Optimize sign extension.

Richard Halkyard (1):
      Reformat comments to style guide rules

Stefan (23):
      Fix colors for #948
      Fixed typos
      Fixed exit code #974
      Fixed C16 #978
      Update c16.sgml
      Update c128.sgml
      Update c64.sgml
      Update cbm510.sgml
      Update cx16.sgml
      Update funcref.sgml
      Update nes.sgml
      Update pce.sgml
      Update plus4.sgml
      Update vic20.sgml
      Update color.s
      Update conio.s
      Update cputc.s
      Update fast.s
      Update isfast.s
      Update revers.s
      Update slow.s
      Update status.s
      Preserve the accu

Stephan Mühlstrasser (5):
      Restructured according to review
      Remove obsolete comment
      Remove source file that was only used for testing
      Address review comments
      Removed redundant LDA

acqn (4):
      Corrected check in OptTransfers2 for register usage. Fixed Issue 992.
      Always insert a LDA after the removed PLA during the optimization in \ 
OptPushPop. Fixed Issue 971.
      Quick fix for the OptPushPop bug reported in Issue #337.
      Just disable OptPushPop if N/Z is used after the PLA. This is a more \ 
conservative way to fix Issue #971.

bbbradsmith (4):
      sim65 common define for paravirt hooks base location allows the loaded \ 
binary to take up as much space as possible restored some documentation of the \ 
hooks but without reference to specific location
      Fix silent crash failure on warning from linker command line define import \ 
size mismatch
      make linker generated export warning conistent with the import warning
      SEGMENT start of 0 should be valid

greg-king5 (1):
      Aligned comment.

itaych (1):
      PMG_SIZE_QUAD is 3, not 2.

jede (28):
      Add page 0 variables from Telemon 2.4
      Add XSCROH & XSCROB value
      Fix bug : gotoxy does not working because Y does not update the adress on \ 
the screen
      Add textcolor and bgcolor.s
      Fix gotoy changecolor
      fix typo
      fix import
      Fix typo and optimize
      Fix label, optimize code
      Fix bug with bgcolor and textcolor
      jmp instead of jsr
      Fix bgcolor and textcolor must return last color, jmp remove.
      Optimize Clrscr
      Cleaning import variables
      Fix comment and gotox force colour change
      Fix bug $FF
      Add cclear and cclearxy
      Fix bug in tgi_line : HRS(X) parameters are 16 bits.
      Fix 16 bits values
      Telestrat joystick management
      Fix typo
      Fix typo
      Fix typo
      Fix bug
      Change name of the driver (telestrat-joy.s renamed to telestrat.s
      Fix eor bug
      Fixed the name of the driver

laubzega (2):
      Fix for #928.
      Minor formatting changes after review.

marko.lauke (2):
      +cc65 inline asm stp mnemonic support
      +code style

mc78 (11):
      Replaced plain 0's and 1's in exit statements with EXIT_SUCCESS or EXIT_FAILURE
      Added enum for cc65 exit codes. replaced stdlib exit code names constants \ 
in libsrc with cc65 exit code named constants
      Added comment to debugger exit with error
      Replaced enum in cc65.h by defines. added comment that cc65 exit constants \ 
should not redefine 0 and 1 as they are reserved for exit_success and \ 
      Removed CC65_ prefixes from exit statements in abort and assert code as \ 
well from definition
      Removed additional exit constants definitions from cc65.h to stdlih.h. \ 
Guarded the definitions by #ifdef. Removed cc65.h includes from abort and assert \ 
      added additional empty line after header guard in cc65.h to conform to \ 
other headers
      Removed unnecessary #include <cc65.h> from convert.c Adjusted block \ 
comments to predominant style
      Changes in INSTALL routine from emd/c128-vdc.s. tmp1 was used at two \ 
places resulting in the bug that VDC_CSET was set to garbage on 16k VDC. \ 
pagecount and curpage were not reset on INSTALL resulting in non-reentrant code \ 
on static linkage of emd driver.
      Added reservation of second byte for pagecount
      Changed the order in which lo/hi bytes of vdc addr are set according to \ 
willimanilys ((z64k) suggestions. Changed offset for vdc ramsize detection from \ 
000 to 000.

mrdudz (2):
      added regression test related to bug #1001
      store y first, then a. fix by willymanilly