Subject: CVS commit: pkgsrc/devel
From: Jonathan Perkin
Date: 2022-08-03 15:06:32
Message id: 20220803130632.C1760FB1A@cvs.NetBSD.org

Log Message:
libtool: Unbreak the 2.4.7 update.

The main issue is that the configure script was generated with a different
version of autoconf compared to upstream, and hardcoded CC='cc -std=gnu11'
which broke inferred tag detection, as well as likely causing other issues
elsewhere.  Generated patches _must_ use the same version as upstream so that
diffs can be reviewed for changes.

While here remove patches for MirBSD and MidnightBSD.  MirBSD was discontinued
many years ago, and support for MidnightBSD was already included upstream.
This significantly simplifies our patches and helps to identify issues.

Bump PKGREVISION of libtool-base and libtool-fortran.

Files:
RevisionActionfile
1.4modifypkgsrc/devel/libtool/patches/patch-libltdl_configure
1.5modifypkgsrc/devel/libtool/patches/patch-configure
1.4modifypkgsrc/devel/libtool/patches/patch-build-aux_ltmain.sh
1.3modifypkgsrc/devel/libtool/patches/manual-ltmain.in
1.9modifypkgsrc/devel/libtool/patches/manual-ltdl.m4
1.50modifypkgsrc/devel/libtool/patches/manual-libtool.m4
1.20modifypkgsrc/devel/libtool-fortran/Makefile
1.124modifypkgsrc/devel/libtool-base/Makefile
1.109modifypkgsrc/devel/libtool/distinfo