./sysutils/xenkernel42, Xen 4.2.x Kernel

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.2.5nb16, Package name: xenkernel42-4.2.5nb16, Maintainer: pkgsrc-users

Xen is a virtual machine monitor which supports running multiple
guests operating systems on a single machine. Guest OSes (also
called "domains") require a modified kernel which supports Xen
hypercalls in replacement to access to the physical hardware. At
boot, the xen kernel is loaded along with the guest kernel for the
first domain (called domain0). domain0 has privileges to access
the physical hardware (PCI and ISA devices), administrate other
domains and provide virtual devices (disks and network) to other
domains.

This package contains the 4.2 Xen4 kernel itself. PCI passthrough is
not supported. PAE is mandatory; on i386 one must use XEN3PAE_DOM[0U].

This is the last release to support python-based tools (xm), rather
than the newer xl. It remains in pkgsrc as a courtesy to those who
have not yet migrated.

This version no longer receives security updates.


Required to build:
[lang/python27] [pkgtools/cwrappers]

Master sites:

SHA1: f42741e4ec174495ace70c4b17a6b9b0e60e798a
RMD160: 7d4f7f1b32ee541d341a756b1f8da02816438d19
Filesize: 15304.614 KB

Version history: (Expand)


CVS history: (Expand)


   2019-12-17 21:26:05 by Greg Troxel | Files touched by this commit (5)
Log message:
sysutils/xen: Explain security/recommended status in DESCR
   2019-12-17 21:19:41 by Greg Troxel | Files touched by this commit (1)
Log message:
sysutils/xen: Note reason why 4.2 still exists.
   2019-07-15 18:24:18 by Nia Alarie | Files touched by this commit (8)
Log message:
Use https for xenproject.org.
   2019-04-25 09:33:32 by Maya Rashish | Files touched by this commit (620)
Log message:
PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.
   2018-07-24 19:29:09 by Maya Rashish | Files touched by this commit (10)
Log message:
sysutils/xen*: invert python version logic, only 2.7 is ok.

Mostly so we don't match python37 on xen 4.11, but also because python3
is a moving target and this saves us having to add the next version.
   2018-07-03 07:03:44 by Adam Ciarcinski | Files touched by this commit (495)
Log message:
extend PYTHON_VERSIONS_ for Python 3.7
   2018-01-15 10:47:55 by Jonathan Perkin | Files touched by this commit (8)
Log message:
xen*: Use SSP_SUPPORTED=no instead of PKGSRC_USE_SSP=no.
   2017-07-24 10:53:45 by Maya Rashish | Files touched by this commit (4)
Log message:
Don't force enable ssp on xenkernel packages. fixes build