./audio/alsa-plugins-pulse, Advanced Linux Sound Architecture (ALSA) - PulseAudio plugin

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.1.1nb5, Package name: alsa-plugins-pulse-1.1.1nb5, Maintainer: pkgsrc-users

The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
functionality to the Linux operating system. ALSA has the following
significant features:

* Efficient support for all types of audio interfaces, from consumer sound
cards to professional multichannel audio interfaces.
* Fully modularized sound drivers.
* SMP and thread-safe design.
* User space library (alsa-lib) to simplify application programming and
provide higher level functionality.
* Support for the older Open Sound System (OSS) API, providing binary
compatibility for most OSS programs.

This package provides a PulseAudio plugin for ALSA.


Required to run:
[audio/pulseaudio] [audio/alsa-lib]

Required to build:
[pkgtools/x11-links] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: 280eb0d9810e463059747d01760a5ac3f44d7057
RMD160: a37a5d87a9760e6e4a1ac46179e5b19dc2e16ee0
Filesize: 357.61 KB

Version history: (Expand)


CVS history: (Expand)


   2018-07-06 17:06:52 by Ryo ONODERA | Files touched by this commit (136)
Log message:
Recursive revbump from audio/pulseaudio
   2018-01-28 21:11:10 by Thomas Klausner | Files touched by this commit (462) | Package updated
Log message:
Bump PKGREVISION for gdbm shlib major bump
   2017-09-08 04:38:46 by Ryo ONODERA | Files touched by this commit (132)
Log message:
Recursive revbump from audio/pulseaudio-11.0
   2017-01-21 21:06:55 by Ryo ONODERA | Files touched by this commit (157)
Log message:
Recursive revbump from audio/pulseaudio-10.0
   2016-08-04 19:03:41 by Ryo ONODERA | Files touched by this commit (145)
Log message:
Recursive revbump from audio/pulseaudio
   2016-04-20 14:10:35 by Niclas Rosenvik | Files touched by this commit (138)
Log message:
Set LICENSE for a lot of audio packages.
   2016-04-15 11:05:41 by Thomas Klausner | Files touched by this commit (4) | Package updated
Log message:
Update alsa-plugins-* to 1.1.1.

No relevant changes for the ones we have in pkgsrc, I think.

Changelog:

Core

    Release v1.1.1

A52 Output plugin

    a52: Fix usage of obsoleted avcodec_*_frame() functions
    a52: Make compatible with ffmpeg 3.0
    a52: fix reported input channel order

Public Parrot Hack rate converter

    pph: include config.h from rate_speexrate.c

Speex PCM plugin

    speex: Add missing include config.h
   2016-02-18 16:17:01 by Thomas Klausner | Files touched by this commit (4) | Package updated
Log message:
Update alsa-plugins-* to 1.1.0:

 Core

    Release v1.1.0
    pph: Fix build with older speex
    pph: include speexdsp_types.h, not speex_types.h

A52 Output plugin

    a52: Fix ioplug version ifdef checks

Arcam AV control plugin

    arcam-av: Include sys/select.h for fd_set definition

Automatic upmix / downmix plugins

    mix: Fix extplug version ifdef checks

Jack PCM plugin

    jack: Fixing a small memory leak

Public Parrot Hack rate converter

    pph: Fix build with older speex
    pph: include speexdsp_types.h, not speex_types.h

PulseAudio -> ALSA plugin

    pulse: Add 24 bit data formats to Pulse plugin.

Rate Converter plugins

    rate: Allow LGPL for libsamplerate commercial licensee