./audio/csound5, Software synthesizer and sequencer

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 5.19.01nb2, Package name: csound5-5.19.01nb2, Maintainer: pkgsrc-users

Csound is a software synthesis package in the tradition of so-called
music-N languages, among which the best-known is Music V. It consists
of an orchestra- and score-driven executable, written in C for
portability. Since Csound is a computational language, it is highly
flexible and efficient; complexity is gained only at the expense of
computation time. Basically Csound reads some files and creates the
result as a file on disk or, on faster machines, through a DAC in real
time.


Required to run:
[graphics/png] [graphics/jpeg] [audio/fluidsynth] [audio/libsndfile] [x11/fltk]

Required to build:
[pkgtools/x11-links] [devel/scons] [pkgtools/cwrappers] [lang/python37]

Master sites:

SHA1: eeeb3591745c5b352b9040a2dfa3805f22f5fbda
RMD160: ceb9952d562c57b09143a47a4d51081753f1b694
Filesize: 9084.498 KB

Version history: (Expand)


CVS history: (Expand)


   2019-04-25 09:33:32 by Maya Rashish | Files touched by this commit (620)
Log message:
PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.
   2019-01-02 19:29:14 by Tobias Nygren | Files touched by this commit (4) | Package updated
Log message:
csound5: catch up with scons update; support building with python 3
   2018-07-03 07:03:44 by Adam Ciarcinski | Files touched by this commit (495)
Log message:
extend PYTHON_VERSIONS_ for Python 3.7
   2017-08-01 16:59:08 by Thomas Klausner | Files touched by this commit (211)
Log message:
Follow some http -> https redirects.
   2017-01-01 15:44:09 by Thomas Klausner | Files touched by this commit (577)
Log message:
Add python-3.6 to incompatible versions.
   2016-07-09 15:04:18 by Thomas Klausner | Files touched by this commit (599)
Log message:
Remove python33: adapt all packages that refer to it.
   2016-02-25 11:15:46 by Jonathan Perkin | Files touched by this commit (14)
Log message:
Use OPSYSVARS.
   2015-12-05 22:26:09 by Adam Ciarcinski | Files touched by this commit (578)
Log message:
Extend PYTHON_VERSIONS_INCOMPATIBLE to 35