./devel/guile-lib, Library functions for Guile, implemented in Scheme

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.2.3, Package name: guile-lib-0.2.3, Maintainer: gdt

Guile-Lib is intended as an accumulation place for pure-scheme Guile
modules, allowing for people to cooperate integrating their generic
Guile modules into a coherent library. Think "a down-scaled,
limited-scope CPAN for Guile".

Also, it can be seen as a code staging area for Guile; the Guile
developers could decide to integrate some of the code into
guile-core. An example for a possible candidate is SRFI-35.

* SSAX, S-Exp-based XML parsing/query/conversion
* HTMLPrag, a permissive ("pragmatic") HTML parser
* Texinfo processing, enabling literate programming
* Unit testing framework ala JUnit
* Logging system
* String routines (wrapping, completion, soundex algorithm)
* OS process chains (think "shell pipes in scheme")
* An LALR parser
* ANSI escape sequence text coloring
* Structured text (plain, texinfo, html)
* SRFI-35 (conditions)


Required to run:
[lang/guile20]

Master sites:

SHA1: 546ca15e963d8137e1cd3e8da4693983b3a30aa8
RMD160: 17ac21126fc9a808775cdce352a3fe9eff3fed1b
Filesize: 547.149 KB

Version history: (Expand)


CVS history: (Expand)


   2016-09-20 02:37:37 by Greg Troxel | Files touched by this commit (3) | Package updated
Log message:
Update to 0.2.3

Upstream changes:

This is a maintenance release, source code is unchanged compare to the previous
release.  This release introduces a guile-lib-1.0.pc, so libs and apps that needs
guile-lib may now use pkgconfig to check if it's available, what version.

Note that starting with this release, the installation location for modules and
compiled files has changed: make sure you uninstall any previous version.

- Modules installation location changed:

	from $(prefix)/share/guile/site
	to $(GUILE_GLOBAL_SITE)

  You will need write privileges to this directory to install guile-lib. You may
  check its location using the folowing command:

	guile -c "(display (%global-site-dir)) (newline)"

- Compiled files installation location changed:

	from $(prefix)/share/guile/site
	to $(GUILE_SITE_CCACHE)

  You will need write privileges to this directory to install guile-lib. You may
  check its location using the folowing command:

	guile -c "(display (%site-ccache-dir)) (newline)"
   2016-09-15 19:05:16 by Thomas Klausner | Files touched by this commit (1)
Log message:
Add pkg-config to tools for proper guile detection.
   2016-09-15 02:00:15 by Greg Troxel | Files touched by this commit (2)
Log message:
Change to guile20 from guile (1.8)

The PLIST drops many things which are part of guile 2.0 and thus not
installed.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2014-12-04 02:05:25 by Greg Troxel | Files touched by this commit (3) | Package updated
Log message:
Update to 0.2.2.

guile-lib 0.2.2 -- 2013-01-31
=============================

* Install (texinfo nodal-tree) for Guile 2.0.

* MD5 bugfixes.

* Better errors in Apicheck.

guile-lib 0.2.1 -- 2011-04-03
=============================

* Updates for Guile 1.8.

Some of the compatibility hacks from 0.2.0 broke Guile-Lib on Guile
1.8.  Thanks to Andreas Rottmann for the various fixes.

guile-lib 0.2.0 -- 2011-03-26
=============================

* Updates for Guile 2.0.

When compiled against Guile 2.0, Guile-Lib no longer installs modules
that have been included in the Guile distribution.  This is an
incompatible change: if you build Guile-Lib against Guile 2.0 and then
use it against 1.8, you will be missing `(sxml simple)' and the other
modules that were incorporated in Guile 2.0.

That said, Guile 2.0 is appoximately 7.1 times as awesome as Guile 1.8,
so you should stop worrying and learn to love it.

guile-lib 0.1.9 -- 2010-08-29
=============================

* Updates for Guile 2.0.

Guile 2.0 has incorporated many modules from Guile-Lib, but all the same
we have to make sure that one Guile-Lib installation works fine with 1.8
and 2.0.

* The default SSAX parser no longer drops whitespace.

We used to drop extraneous whitespace when using the default XML parser,
but strictly speaking, this loses information. Guile-Lib now preserves
whitespace in the resulting SXML.

* SSAX supports UTF-8 output on Guile 1.8.

Guile 1.8 naively treats characters as bytes, not understanding
unicode. Still sometimes it's useful to emit UTF-8 sequences in Guile
1.8, which is what this SSAX does. Note that Guile 2.0 includes its own
SSAX, and handles unicode natively.

* Expose ssax:predefined-parsed-entities

Allows the user to define &foo; XML entities.

* License changed to GPL and LGPL, version 3 or later.

See the specific modules for their licenses.

* Removed modules: (math rationalize), (scheme session), SRFIs 34,35,40

Guile 1.8 and above support rationalize natively. The improvements in
(scheme session) are in Guile now, as are SRFIs 34 and 35. SRFI 40 is
withdrawn, in favor of SRFI 41.

* Removed module (container queue)

Use (ice-9 q) instead.

* Call tree analysis in statprof

Statprof can save away the various call trees that it samples for later
analysis. See the statprof documentation, for more information.
   2012-10-31 12:19:55 by Aleksej Saushev | Files touched by this commit (1460)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2010-03-24 20:43:29 by Aleksej Saushev | Files touched by this commit (75) | Package updated
Log message:
Recursive revision bump for GMP update.
   2009-12-15 22:40:02 by Joerg Sonnenberger | Files touched by this commit (22)
Log message:
Recursive bump for libltdl