./devel/p5-Config-Any, Perl extension for handling config files

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.32nb3, Package name: p5-Config-Any-0.32nb3, Maintainer: pkgsrc-users

Load configuration from different file formats, transparently


Required to run:
[lang/perl5] [devel/p5-Module-Pluggable]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: c52d72e6c91162615675989b5cfe0520b4ab8853
RMD160: d0eb69ce2f3226ee7b6180f1da5ef3655739a6bd
Filesize: 20.552 KB

Version history: (Expand)


CVS history: (Expand)


   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-04-25 15:54:08 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Config-Any to 0.32
-----------------------------------
0.32 - 2017-04-23
    - allow YAML::Syck to fail its error tests
    - improved diagnostics in YAML test
    - include a full list of modules used in JSON documentation
    - be less strict checking error messages in tests
    - add test to report optional prereq versions

0.31 - 2017-04-23
    - test cleanups
    - better diagnostics for test failures
    - don't run pod tests on user machines
    - handle unsupported Config::General versions better
    - refactored module loading
    - include optional prereqs in suggests
    - pod cleanups
   2017-04-09 10:29:48 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.30

Upstream changes:
0.30 - 2017-03-28
    - don't use YAML::Syck on perl 5.8.8 or below, where it is broken
    - ensure tarball does not contain SCHILY headers
   2017-03-11 12:04:10 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.29

Upstream changes:
0.29 - 2017-02-27
    - allow loading relative perl files even under taint mode (RT#120371)
    - throw errors when attempting to load perl files that do not exist

0.28 - 2017-02-21
    - support Cpanel::JSON::XS and JSON::MaybeXS for loading JSON
    - decode UTF-8 config files properly
    - load perl files directly, never possibly searching @INC
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.