./devel/p5-Devel-CheckOS, Perl extension to check what OS we are running on

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.81nb2, Package name: p5-Devel-CheckOS-1.81nb2, Maintainer: pkgsrc-users

Devel::CheckOS provides a more friendly interface to $^O, and also lets you
check for various OS "families" such as "Unix", which includes things like
Linux, Solaris, AIX etc.


Required to run:
[lang/perl5] [devel/p5-File-Find-Rule] [devel/p5-Data-Compare]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 08cfa444a2209503980f77d89aa86c9836e6223b
RMD160: 8cfa7ce0ac7114fc08286dedaa6c35c72bfe4f55
Filesize: 31.692 KB

Version history: (Expand)


CVS history: (Expand)


   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-02-02 07:52:54 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.81

Upstream changes:
1.81    2018-01-23      Restore 5.6 and 5.8 compatibility;
                        Cope better in tests when @INC is humungous
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-05-26 14:57:39 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Devel-CheckOS to 1.80
--------------------------------------
1.80    2017-05-24
   Fix bug where tests would fail if
   AUTOMATED_TESTING=1 on perl 5.26 and higher;
   For some reason that made it break on 5.8.9,
   but I don't really care
   2016-11-06 05:38:18 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Devel-CheckOS to 1.79
--------------------------------------
1.79    2016-10-30 Fix another minor bug
                   (https://github.com/DrHyde/perl-modules- … /issues/17)

1.78    2016-10-30 Fix an isue that made it uninstallable on some systems
		   (https://github.com/DrHyde/perl-modules- … /issues/16)
   2016-10-30 06:19:21 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Devel-CheckOS to 1.77
--------------------------------------
1.77    2016-10-21      Add MacOSX:v10_11 and ..._12