./devel/p5-Inline, Perl5 module for writing Perl subroutines in other languages

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.83, Package name: p5-Inline-0.83, Maintainer: pkgsrc-users

Inline lets you write Perl subroutines in other programming languages
like C, C++, Java, Python, Tcl and even Assembly. You don't need to
compile anything. All the details are handled transparently so you can
just run your Perl script like normal.


Required to run:
[lang/perl5] [devel/p5-Parse-RecDescent] [devel/p5-Test-Warn]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 62962fd16386138e53c27a216d622a765f119b07
RMD160: 622f966cbbd616b302144a298529ce7e7fb1aff7
Filesize: 77.105 KB

Version history: (Expand)


CVS history: (Expand)


   2019-06-08 05:44:32 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.83

Upstream changes:
0.83 Sun 28 Apr 2019 11:30:37 AM CEST
 - Reference Inline::Module in docs related to installation (PR #68
   @nrdvana++)
 - create_config_file: don't accidentally skip rest of directory scanning
   (PR #73 @eserte++)
 - Merge per-language config, not overwrite (PR #71 @mohawk++)
   2019-04-07 04:01:15 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.82

Upstream changes:
0.82 Sun 31 Mar 2019 04:10:24 PM CEST
 - Another fix for @INC PR#69 TINITA
   2019-02-09 01:47:03 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.81

Upstream changes:
0.81 Sun 03 Feb 2019 04:42:05 PM CET
 - Regular release, see developer releases

0.80_03 Fri 01 Feb 2019 11:26:18 PM CET
 - Fix @inc, add another exception for Inline::C (SISYPHUS++)

0.80_02 Fri Jun 22 22:21:11 MDT 2018
 - Revert PR/61 - failed on travis

0.80_01 Fri Jun 22 21:39:49 MDT 2018
 - PR/59 @pypt++ Travis test against Perl 5.22, 5.24, 5.26
 - PR/60 @pypt++ Calculate MD5 hashes of UTF-8 source by encoding it first
 - PR/61 @rurban++ Fix wrong -I in subcmd
 - PR/66 @soren++ Fix failing tests on systems missing perldiag.pod
 - PR/67 NERDVANA++ Relax the version requirement for installing modules

0.80 Fri Mar 13 20:03:52 PDT 2015
 - Fix dependency problem in Inline::MakeMaker affecting parallel builds
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg