./devel/p5-List-SomeUtils-XS, XS implementation for List::SomeUtils

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.58nb1, Package name: p5-List-SomeUtils-XS-0.58nb1, Maintainer: pkgsrc-users

XS implementation for List::SomeUtils.


Required to run:
[lang/perl5]

Required to build:
[devel/p5-Test-LeakTrace] [devel/p5-Test-Warnings] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: a8e5017984f68fd9885b4a78678ed654669a69ab
RMD160: bd6bc0c37a84675c6329c50859e7cd8feff5e246
Filesize: 91.982 KB

Version history: (Expand)


CVS history: (Expand)


   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-06-18 16:52:53 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.58

Upstream changes:
0.58     2018-06-08

- Re-release to fix the generated Makefile.PL. We do not want to try to build
  the XS code with compiler warnings enabled except on Perl 5.24+. There are
  unavoidable warnings with older Perls. If you tried to install this distro
  in an environment where AUTHOR_TESTING was set, these warnings would be
  enabled, along with "-Werror", causing the build to fail
  completely. Reported by Olaf Alders. GH #3.
   2018-05-30 03:38:31 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.57

Upstream changes:
0.57     2018-05-26

- Fix C compiler warnings. Reported by Jim Keenan. GH #2.
   2017-12-30 14:55:10 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-List-SomeUtils-XS: update to 0.56.

0.56     2017-12-12

- The one() sub returned true when given an empty list, but it should return
  false. Reported by randyl. GH #3.
   2017-08-14 20:59:06 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated p5-List-SomeUtils-XS to 0.55.

0.55     2017-07-23

- Skip all the tests unless List::SomeUtils 0.56 is installed. This fixes the
  issue where trying to install the new List::SomeUtils ends up pulling this
  distribution, which then fails because an older LSU is installed but doesn't
  export mode(). Reported by John SJ Anderson. GH #1.

0.54     2017-07-22

- Added a new function, mode(), requested by Jerrad Pierce. GH #2.
   2017-06-15 16:12:55 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-List-SomeUtils-XS to 0.53
------------------------------------------
0.53     2017-06-01
- Moved issue tracking to GitHub.
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.