./devel/p5-Test-Pod-Coverage, Check for pod coverage in your distribution

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.10nb3, Package name: p5-Test-Pod-Coverage-1.10nb3, Maintainer: pkgsrc-users

Check for pod coverage in your distribution.


Required to run:
[textproc/p5-Pod-Coverage]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 284165385957ff069791c84eb3bf2006e603d701
RMD160: 1d72fe370c23099028b02b20aefb5516cbdf8433
Filesize: 7.894 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-09-06 14:42:37 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 1.10. Set LICENSE.

1.10 2014-07-17 NEILB
    - Changed license to Artistic 2.0, at PETDANCE's request.
    - Added README
    - Moved Coverage.pm to lib/Test/Pod/Coverage.pm
    - Min perl version now set to 5.006 in both code and dist metadata.
      Addresses RT#21564 from ANDK++
    - Added DESCRIPTION section to pod (RT#28715 JEREMIAH++),
      and changed to a minimal SYNOPSIS, with everything else moved
      to the DESCRIPTION.
    - The "no verbose" tests in t/nosymbols.t weren't ensuring that the
      tests were running with HARNESS_VERBOSE set to false. You could set
      that true in your environment and break the test.
      RT#53947 - thanks to Pete Armstrong.
    - Makefile.PL: Ensured all prereqs listed in PREREQ_PM,
      and TEST_REQUIRES set if a recent enough ExtUtils::MakeMaker.
    - Added github repo to pod and dist metadata
    - Deleted the old META.yml, so new MYMETA.{yml,json} will be generated.
    - Reformatted as per CPAN::Changes::Spec

1.09_01 2014-07-08 NEILB
    - Specified license as 'Perl' in metadata, to match doc.
    - All of the changes in 1.10 were first done in this developer release,
      apart from the change to Artistic License 2.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2012-10-31 12:19:55 by Aleksej Saushev | Files touched by this commit (1460)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.