./editors/nvi-m17n, Clone of vi/ex, with multilingual patch

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.79.20040608nb6, Package name: nvi-m17n-1.79.20040608nb6, Maintainer: pkgsrc-users

This ports contains multilingualized nex/nvi.

nex/nvi is a freely redistributable implementation of ex/vi text
editors originally distributed as part of the Fourth Berkeley
Software Distribution (4BSD), by the University of California,
Berkeley.

Multilingual patch enables you to use the following multilingual
encoding methods, such as:
none iso-8859-[1234789] latin1 latin2
euc-jp-1978 euc-jp euc-jp-1983 euc-jp-1990 euc-cn euc-kr
iso-2022-cn iso-2022-jp iso-2022-kr
iso-2022-7-1 iso-2022-7-2 iso-2022-8-2
sjis big5 hz euc-tw
Multilingual support has been set up to use some of the above (guess from
the name of the ports/packages) as default value.
You can change encoding style on the fly, or by setting up ~/.exrc.
With configurations, for Japanese encodings, you can also enjoy the
embedded canna support.
See /usr/local/share/vi/README.* for details of multilingual patch.

original distribution site:
ftp://ftp.cs.berkeley.edu/ucb/4bsd/nvi-1.79.tar.gz
ftp://ftp.foretune.co.jp/pub/tools/nvi-m17n/


Required to run:
[lang/perl5] [inputmethod/canna-lib]

Required to build:
[pkgtools/cwrappers]

Package options: canna

Master sites:

SHA1: 65b49768783372609278ecedd63caa8c1547aa2a
RMD160: 1c39d480e0d30a87fc061c3219354b50011a8621
Filesize: 1265.04 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-07 20:00:55 by Maya Rashish | Files touched by this commit (3) | Package updated
Log message:
nvi-m17n: successfully detect file encoding also in the case where more
than one encoding matches, by comparing with 'and bitmask' rather than
equality to bitmask.

Bump PKGREVISION for functional change.

Patch from Yasuhito FUTATSUKI in PR pkg/51792
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2015-11-03 04:32:24 by Alistair G. Crooks | Files touched by this commit (138)
Log message:
Add SHA512 digests for distfiles for editors category

Problems found with existing distfiles:
	distfiles/javascript-2.1b1.el
	distfiles/yEd-3.14.2.zip
No changes made to the javascript-mode or yEd distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2013-04-06 17:46:40 by Blue Rats | Files touched by this commit (52)
Log message:
'You can use "foo" instead of "${WRKSRC}/foo".'
   2012-10-03 23:59:10 by Thomas Klausner | Files touched by this commit (2798)
Log message:
Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.