./emulators/tme, The Machine Emulator

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.8nb34, Package name: tme-0.8nb34, Maintainer: pkgsrc-users

The Machine Emulator, or tme, is a program that provides a general-
purpose framework for computer emulation. The first machine that tme
could emulate was the Sun 2/120, one of the first widely available Sun
workstations. Other emulations include the Sun 3/150 and SPARCstation 2.


Required to run:
[lang/perl5] [devel/libltdl] [x11/gtk2]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: dd4f3421c20ceed548c5328a21dbb26e80f46b9c
RMD160: 6bd505c5fa7810d37f436883383c4ba655df2ded
Filesize: 2050.901 KB

Version history: (Expand)


CVS history: (Expand)


   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2018-01-01 23:30:04 by Roland Illig | Files touched by this commit (537)
Log message:
Sort PLIST files.

Unsorted entries in PLIST files have generated a pkglint warning for at
least 12 years. Somewhat more recently, pkglint has learned to sort
PLIST files automatically. Since pkglint 5.4.23, the sorting is only
done in obvious, simple cases. These have been applied by running:

  pkglint -Cnone,PLIST -Wnone,plist-sort -r -F
   2017-02-12 07:26:18 by Ryo ONODERA | Files touched by this commit (1451)
Log message:
Recursive revbump from fonts/harfbuzz
   2017-02-06 14:56:14 by Thomas Klausner | Files touched by this commit (1452)
Log message:
Recursive bump for harfbuzz's new graphite2 dependency.
   2016-08-03 12:23:40 by Adam Ciarcinski | Files touched by this commit (1248) | Package updated
Log message:
Revbump after graphics/gd update
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2016-04-04 20:00:16 by matthew green | Files touched by this commit (1) | Package updated
Log message:
don't bother turning off every individual warning that comes up with
modern compilers, turn off -Werror globally and avoid the creeping
failures each compiler update (this affects both gcc and clang.)

apply -fno-strict-aliasing for all foreseeable future gcc versions.

this now works with gcc 5.3.

ok wiz, joerg