Subject: CVS commit: pkgsrc/security
From: Filip Hajny
Date: 2018-01-22 14:37:25
Message id: 20180122133725.5DB3CFBDE@cvs.NetBSD.org

Log Message:
Update security/py-{acme,certbot} to 0.21.0.

### Added

- Support for the HTTP-01 challenge type was added to our Apache and Nginx
  plugins.
- IPv6 support was added to the Nginx plugin.
- Support for automatically creating server blocks based on the default server
  block was added to the Nginx plugin.
- The flags --delete-after-revoke and --no-delete-after-revoke were added
  allowing users to control whether the revoke subcommand also deletes the
  certificates it is revoking.

### Changed

- We deprecated support for Python 2.6 and Python 3.3 in Certbot and its ACME
  library.
- We split our implementation of JOSE (Javascript Object Signing and
  Encryption) out of our ACME library and into a separate package named josepy.
- We updated the ciphersuites used in Apache to the new values recommended by
  Mozilla

### Fixed

- An issue with our Apache plugin on Gentoo due to differences in their
  apache2ctl command have been resolved.

Files:
RevisionActionfile
1.1removepkgsrc/security/py-acme/ALTERNATIVES
1.19modifypkgsrc/security/py-certbot/distinfo
1.19modifypkgsrc/security/py-certbot/Makefile.common
1.7modifypkgsrc/security/py-certbot/Makefile
1.7modifypkgsrc/security/py-acme/PLIST
1.9modifypkgsrc/security/py-acme/Makefile