Subject: CVS commit: pkgsrc/print/cups-filters
From: Adam Ciarcinski
Date: 2018-08-27 08:51:14
Message id: 20180827065114.1D6C4FBF8@cvs.NetBSD.org

Log Message:
cups-filters: updated to 1.21.1

CHANGES IN V1.21.1
- foomatic-rip: Fixed segmentation fault caused by wrong
  Coverity Scan issue fix.
- Build system: Require QPDF 8.1.0 or later as it is needed by
  bannertopdf.

CHANGES IN V1.21.0
- libcupsfilters, cups-browsed, driverless, foomatic-rip,
  parallel: Silenced warnings from newest gcc.
- libcupsfilters: When generating a PPD for driverless
  printing on a remote IPP printer, make pdftopdf not being
  run by the local queue if the remote queue is a CUPS queue
  to avoid running pdftopdf twice.
- libcupsfilters, cups-browsed, driverless, bannertopdf,
  foomatic-rip, pdftops, pdftoraster, rastertops,
  rastertoescpx, sys5ippprinter, beh: Fixed Coverity Scan
  issues.
- bannertopdf: Switched over from using Poppler to using QPDF
  for generating the PDF pages. With Poppler unstable APIs
  were used which were subject to change. Thanks to Sahil
  Arora for this project in the Google Summer of Code 2018
- cups-browsed: Manually defined clusters ("Cluster" directive
  in cups-browsed.conf) caused cups-browsed to crash.

Files:
RevisionActionfile
1.57modifypkgsrc/print/cups-filters/distinfo
1.103modifypkgsrc/print/cups-filters/Makefile