./pkgtools/pkg_filecheck, Check for files not owned by any package

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.4nb6, Package name: pkg_filecheck-0.4nb6, Maintainer: pkgsrc-users

pkg_filecheck compares the file system contents with the list of
files recorded in the package database, and reports any files that
are in the file system, but not in the database.


Required to run:
[lang/perl5]

Version history: (Expand)


CVS history: (Expand)


   2016-11-28 05:56:37 by Darrin B. Jewell | Files touched by this commit (1)
Log message:
add nbcompat.h include to get uint32_t
fixes build on darwin
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2016-06-11 23:34:54 by David A. Holland | Files touched by this commit (1)
Log message:
Add a BUG: you can't ignore single files, only whole subtrees, but
there are a number of files from pkgsrc that ought to be ignored by
default, such as $PREFIX/info/dir.

Ride previous version bump.
   2016-06-11 23:26:19 by David A. Holland | Files touched by this commit (2) | Package updated
Log message:
Add patch from Tim Zingelman in PR 46421 to make it work on machines
whose libdb is not the db-1.85 that's in the libc of 4.4 derivates.

Since this program reads the package database it must use the same
libdb as pkg_install, and that's the one in libnbcompat rather than
the one you get from bdb.buildlink3.mk.

Bump PKGREVISION to 5.
   2015-07-04 18:18:44 by Joerg Sonnenberger | Files touched by this commit (222)
Log message:
Remove USE_X11BASE and X11PREFIX.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2014-03-03 05:43:49 by OBATA Akio | Files touched by this commit (1)
Log message:
LICENSE= modified-bsd (sources) AND 2-clause-bsd (man)