./print/p5-biblatex-biber, Replacement of bibtex for users of BibLaTeX

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.7, Package name: p5-biblatex-biber-2.7, Maintainer: pkgsrc-users

Biber is a BibTeX replacement for users of biblatex, with full
Unicode support.

Biber is written in Perl with the aim of providing a customised
and sophisticated data preparation backend for biblatex.


Required to run:
[www/p5-libwww] [lang/perl5] [time/p5-DateTime-Format-Builder] [devel/p5-File-Slurp] [devel/p5-Class-Accessor] [devel/p5-Data-Dump] [devel/p5-List-MoreUtils] [devel/p5-IPC-Run3] [devel/p5-Log-Log4perl] [devel/p5-Data-Compare] [devel/p5-IPC-Cmd] [devel/p5-List-AllUtils] [devel/p5-Data-Uniqid] [misc/p5-Business-ISMN] [misc/p5-Business-ISSN] [devel/p5-autovivification] [devel/p5-List-MoreUtils-XS] [devel/p5-Sort-Key] [time/p5-DateTime-Calendar-Julian]

Required to build:
[devel/p5-Module-Build] [devel/p5-Config-AutoConf] [devel/p5-ExtUtils-LibBuilder] [pkgtools/cwrappers]

Master sites:

SHA1: dda7b8fd3f627d93fa896d1255900782cb79cf14
RMD160: 50f689a15bde19959ed261cea1c105fa815ab5a7
Filesize: 1244.84 KB

Version history: (Expand)


CVS history: (Expand)


   2017-08-01 15:33:44 by Mark Davies | Files touched by this commit (2) | Package updated
Log message:
Update p5-biblatex-biber to 2.7

2.7    (2016-12-08)
       * New option (--nouri-encode) to prevent URL encoding of URLs. Avoids
         breaking display of URLS which contain non-ASCII.
       * Misc bug fixes
2.6    (2016-09-10)
       * Improved tool mode bibtex output. This has some normalisation
         consequences for YEAR and custom fields. See PDF doc.
       * Support for new \ifuniquebaretitle test
       * Sourcemaps can now be restricted to particular refsections
       * Perl 5.24 is now required due to use of postfix deref notation
       * Removed RIS input driver due to lack of use
       * Added extended name format - see documentation
       * Added notfield function to sourcemaps - see documentation
2.5    (2016-05-10)
       * Added data annotations feature - see biblatex documentation.
       * Removed the "latinkeys.txt" Unicode::Collate table. This is now
         pointless because the compiled 'allkeys.txt' is faster and complete.
       * Incompatible biblatex/biber version is now a fatal error.
       * Significant performance improvements, particularly in sorting
         subsystem.
       * Addition of new bblXML output format and associated RelaxNG XML
         schema based on active datamodel.
       * Integration with new biblatex 3.4 labelprefix name change and
         refcontext option.
       * Integration with new biblatex 3.4 \DeclareDatafieldSet
         functionality.
       * Improved sourcemap looping functionality
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-23 23:56:07 by Mark Davies | Files touched by this commit (1)
Log message:
Remove redundant patch.
   2016-04-23 23:37:47 by Mark Davies | Files touched by this commit (2) | Package updated
Log message:
Update p5-biblatex-biber to 2.4

2.4    (2016-03-01)
   * Misc bug fixes
   * There is now a 64-bit windows build built on windows 10
   * Biblatexml datasources now support sourcemapping and have a schema
     automatically generated from the datamodel. See new biber options
     'validate-bltxml' and 'no-bltxml-schema' in --help output.
   * New functionality in sourcemaps for creating new entries and
     looping over specified fields.
   * Sorting key used to sort names is now customisable. See
     \DeclareSortingNamekeyScheme in biblatex manual.
   * Support for Zotero RDF/XML and Endnote removed. These were
     experimental and messy.
2.3    (2015-12-28)
   * Misc bug fixes
2.2    (2015-10-21)
   * Tool mode now preserves comments at the end of the file
   * New ISBN formatting options for biber (--isbn10, --isnb13,
     --isbn-normalise)
   * Implemented way of ignoring certain regexps when counting
     fixed-width string in labels (see biblatex \DeclareNolabelwidthcount
     macro)
   * Updated binary builds to perl 5.22
   * Cygwin binary build is now handled by Texlive builders
   * Misc bug fixes
2.1    (2015-05-06)
   * Misc bug fixes
2.0    (2015-04-20)
   * Misc bug fixes
   * New negated "per type" sourcemap verb for negating the application
     of maps to specific entry types
   * New "entry clone" sourcemap verb for cloning entries during
     sourcemapping. See PDF documentation for biber.
   * Added range length calculation support. Biber now calculates the length
     of ranges for biblatex and can handle roman numerals, including just
     about any UTF-8 composed, non-composed or compat versions
   * Complete re-write of the biblatex use* name functionality now
     automatically supports all name fields defined in the data model. See
     biblatex manual
   * Moved labelname and labeltitle resolution from biber to biblatex for
     more flexibility and future extensions
   * Moved to perl 5.20 for all internals and builds
   2016-03-30 07:33:00 by Mark Davies | Files touched by this commit (3) | Package updated
Log message:
minimal fix for use with perl 5.22. bump PKGREVISION.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg